Tools wont work with custom rigs

What do you want to achieve?
Me and @Gravity_Defier have been working on custom character rigs and we want to be able to equip tools.
What is the issue?
The issue is that when we try to equip the tool, the tool doesn’t weld to the character’s hand. The tool Equipped event also doesn’t call. Therefore, it seems as if the tool was never equipped, although the tool is present in the character.

What solutions have you tried so far?
I have tried using the custom character creator plugin, searched the devforum, and also searched on google. I used the custom character creator plugin to rotate the joints. It seems as if no one else has every had this issue before. We have also tried editing the the humanoid properties but to no solution.

1 Like

The Parts and (Motor6Ds if R6 afaik) related to the Right Arm must be named correctly.

Are you using R6 or R15?
Can you show a screenshot of how your Parts and Motor6Ds are named?

1 Like

We’re using a custom rig with an extra part on the arm and modified dimensions.

Could that extra shoulder part be the cause of the problem?

Are you using R6 or R15?
What’s that extra RightShoulder part?

image

Red circle, the rightshoulder is the added part for the character design. I don’t think it’s either r6 or r15 because it’s a custom rig, should we remove that part and use a more vanilla base?

The Humanoid has a RigType property. Please check that.
I’m talking about the duplicate RightShoulder part. There’s two of them.

You might be able to get away with the rig as it is now if we figure out what’s wrong, but if you want a quickfix instead, you could use the regular R15 setup and simply have the additional shoulder parts rigged off the normal UpperArm part, instead of being directly inline with the limb.

2 Likes

That was it! It was on R6 rigtype. I guess we had multiple copies lying around and got it mixed up. Thank you!

1 Like