Torso frozen when tool equipped? please help

i made a custom running/walking animation for my game. but whenever i pull out a tool, the torso freezes, the torso is unchecked though.

Screenshot_32

is this like a default setting for the torso to be frozen when a tool is equipped? please respond i need help with this

6 Likes

Unless you override the default Torso animation, it will not follow the rest of the joints. The default for any joint is for its Motor6d to be idle( frozen in place at its origin position with no Motor6d influence ), unless you specifically animate it.

Being unchecked means that the according joint is not under the influence of the animation, and does not have any KeyFrame’s. Do you already have the torso implemented into your run animation track?

1 Like

some of that i did not understand, but to answer your question: yes, the torso does move in the running animation, the tools animations are all set to action, while the running animation is set to movement.

Let me state it simpler. If you are not specifically animating the Torso in your run animation, to be where you want it to be, it is not going to move and will remain at a still. For the Torso to do what you want, you need to give it a spot in the animation track.

If you don’t animate the Torso, it will just be frozen in place, since there is no animation acting on it.

the torso does have a spot in the animation track…

Screenshot_130

2 Likes

I thought the image you originally used in the original post was the run animation. My bad!

Does the Torso appear as you wish when running the animation in the Animation Editor?

Also, you should probably switch to using the new animation editor, as that version is discontinued.

Your game is set to work with R6 characters inside game settings, right @ImprinintInc?

yep

its a different tool but has the same issue

can you just give me a quick overview of what i should have in order for it to work

1 Like

I’m not sure what the issue could be. Do you have R6 enabled in character settings?

If you are using a different rig type in the Animation Editor, than in the game settings, you are going to have to choose one.

2 Likes

im really confused. i been trying to solve this problem for so long

Did you try what I mentioned above? If that isn’t the issue, than I am stumped.

what should the animations be set to? i gave the torso a spot in the tool anim a spot in the animation editor. like should the tool or the running anim be set to action, movement, idle, etc?

What I meant was, are your animation Dummie and your Player Character of the same rig type? Are they both R6, for instance?

yes. they are. but my question is what should the animations typed be set to

If you need them to override everything else, you should set the AnimationPriority to “Action”.

1 Like

the torso has a spot in the tools animation. the tool animationpriority is set to action, the running animations priority is set to movement, i still get the same problem.

2 Likes

i dont know what to do anymore i’ve done everything and nothing works

This is indeed very strange, and frustrating.
Unless someone else comes up with a solution, I would try creating a new sword animation, by copy and pasting keyframes over. Maybe starting with a blank slate will solve it.

2 Likes

i found the solution its in the animate script provided by roblox you need to just get rid of these lines
image
i put – to block it then it should be fixed the tool for some reason still has the animations on lol

7 Likes