Trade notification stuck despite no pending trades

On June 21st I noticed I had a trade inbound on my home screen when I clicked on the trade they declined the trade, I clicked back on the home screen, the trade icon was still showing (as you can see in the video below) even though they declined the trade.

Still nothing on the trading page, I have tried multiple methods: Logging out my account then logging back in, tried my privacy settings and notification settings turning them off and back on, still nothing.

This started happening June 21, around 3:30AM BST Uk. - Video Proof
Capture 1 - Picture Proof


Thanks for the report! We’ve filed this internally and we’ll follow up here when we have an update for you.

1 Like

I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved?

This is currently happening to me too.

Logged out before, cleared cookies, tried on a different device. That 1 notification never goes away, if someone sends a trade, it’ll go to 2. Been a thing for months now, didn’t bother about it until I checked this. Not really a big deal but something that should be acknowledged.

I’m on Google Chrome
Mac Specs :

Alright, when there is an update to this issue i will pass it on.


Still happening as of July 2022.


This is also happening to me. When I go to decline a trade, the number next to the trade tab will not go away. :frowning: this seems to last for days at a time.


Can confirm this is happening to me as well


Still happening as of early 2023. Trade notifications awkwardly linger when no trades are present.


This just happened to me a few hours ago, a trade transaction failed because the other recipient was trying to give a nontradable accessory. And now I am stuck with “1” notification on my trade button.

1 Like

This is happening to me too.

Just accepted a trade with someone and now I’m stuck with the (1) counter on my trade icon. It bothers me a lot and I hope it gets fixed soon.



Still bothers me as well. Been this way for years now?



Last month we deployed an update that dealt with the issue.
Please let us know if anyone is still experience similar symptoms or is experiencing the symptoms again.