Transform tool bug

So I was using the transform tool and I misclicked a part and this error appeared.


This is my first time in a while that I used studio so Im not sure when this started happening

Did someone misspell workspace?

Not sure but is “Worksapce” supposed to be “Workspace” ? I am not sure because I am not the best scripter, but hope this helps.

That is the error itself. This bug is not on my script, its on Roblox’s Transform tool

This is a bug… I expected this to be noticed after 3 days and patched, but it’s not. The transform tool is completely useless right now and due to that, it’s slowing down my workflow. I generally hope this stupid typo is fixed so I can use the editor again…

The error is located in the script “Precision” on line 3017

I’ve tried to reupload the plugin with the patch, but Roblox limits me.

1 Like

I tried to use support for it to be fixed but they didn’t help much.

Apparently CanQuery beta enables “DraggerBruteForceAll” enginefeature which makes that code run, disabling it will make dragging work.

1 Like

Been 8+ days of this going on, generally tired of how Roblox deals with this, all they have to do is edit a single typo.

Nice to know, but there’s stupid a typo in the code “worksapce”, and doing this disables a feature that I wish to be enabled. It’s a loose, loose until Roblox fixes this.

I have reported this as a bug also now for anyone in topic wanting to see: Transform Tool Broken: Code typo broke it "Worksapce"

1 Like

Relax, just rename workspace to “Worksapce” ! And it would probably fix in a flick of a finger. When it’s patched, rename it to normal workspace.

F3X is also a temp solution too

That wouldn’t work because they indexed “Part” for raycastresult, not “Instance”, so it’d still error.

Also you can just disable canquery beta for it to work.