Transparent Parts Incorrectly Cause Scenes To Be Over-Exposed, Interferes With Bloom

So, here’s a scene as it looks normally. Note the room is currently nearly pitch black, and you cant make out details.

Now here’s the exact same scene, but a block of light blue, partially transparent, smooth plastic is placed infront of the camera:

Woah! What the heck happened?? It now looks extremely brightly lit, and rather over-exposed. Now think about the physics of this - a transparent piece of blue plastic cannot brighten the scene itself, it is only able to block light, in this case red and green, from passing through it, so in no circumstances should looking at a scene through a transparent object make details, such as the pattern of light leaking in the ceiling here, that are unable to be made out normally due to being unlit, suddenly easy and clear to see. You don’t look out your window at night at suddenly find out you can make out the leaves on the pitch-black trees just because your window is between you.

Now this can be solved by making the block colour black, but now we have a new problem:
a) Black windows look weird
b) All the neon in the scene now loses its bloom effect when viewed through the glass.

These two issue combined create a catch 22 that ruins the visual design of the centerpiece of Innovation Arctic Base, and if it wasn’t for my colleague having already re-lit half the game for Voxel lighting, I would be returning to legacy.

(The bloom effect applies in reverse too - white parts exaggerate bloom which can also be problematic)

Edit 2: the difference is much more noticeable on my laptop than my phone!

6 Likes

Legacy:

Voxel:

Edit:
Note the block on the far right is glass instead of smooth plastic. This behaves much more realistically, but only for people with a high enough graphics setting, otherwise it is identical to plastic.

1 Like

You probably need to tweak the lights and lighting properties. This article might help:

https://developer.roblox.com/resources/devblog---future-is-bright

Thanks for the article, but this is an issue specifically with using transparent parts, and these settings are not having any affect on that.

Changing the block color to black removes the weird brightness increase, but as a consequence also negates neon:

Now I better understand what is going on, I have rewritten this post to more clearly express the issue and why it should be changed.

It has been years and this bug is still occurring. Future is bright phase 3 is out, and it’s nearly impossible to achieve realistic lighting with transparent objects around. Especially when you are working with things like beams and particles for lighting, since nearly every object that can be transparent makes the objects behind it seem lit or brighter.

Thank you for submitting this report. We are currently reviewing all bug reports to ensure we have not overlooked any ongoing issues. Since this issue was reported over two years ago, can you please confirm you are still experiencing the problem? If so, please respond to this thread, and we will investigate. If we do not receive any response within 30 days, we will consider this matter resolved. Thank you.

1 Like

Sorry, I’m outside your 30 days, but I can confirm that using Future Lighting, bloom effects are lost when viewed through transparent objects. Here is an example of some white neon seen through 0.8 transparency plastic on the left and a beam effect on the right:

image

It looks pretty bad in game.

I see that the problem from the beam transparency can be alleviated by increasing the Light Emission value for the beam to 0.8+