TS:ReserveServer not working

Hello everyone, new scripter and new member of DevForum here!

I’m currently making a story game using Ponchokings’ tutorials, I’m using his Tutorial Gate in my game (Tutorial Gate - Roblox). As shown in his video, what I need to do is insert my placeId and I’m good to go. Everything runs smoothly in his video, however, I’m on the opposite situation. I keep getting HTTP 403 (Forbidden) at line 41, please refer to the screenshot below:


I have also tried to create a new testing script with Roblox’s Developer page method (https://developer.roblox.com/en-us/api-reference/function/TeleportService/ReserveServer) but it the output is still the same - HTTP 403 (Forbidden). I’ve also tried to enable API access and HTTP request, still not working.

Any ideas on why it’s not working? Thanks in advance!
(Also, sorry for my horrible English. :p)

1 Like

The problem is you can’t teleport through the roblox studio.

I have also made a camping game using Ponchokings tutorial.
Hope your’s will get famous. :smiley:

Whoops, I forgot to include that I also tried in a public server but it’s not teleporting me. Also, thank you! :slight_smile:

@amalnk0007 is correct, roblox studios servers are run locally and are not able to create Reserved Servers via it,

I would try programming this and therefore testing it out in the physical game to make sure it works.
Keep in mind if you make a ReservedServer you will need to teleport them.

Hope this helps.

Can you post the line where you are getting the main issue and what console outputs please?

and the code running the issue in question.

I prefer removing the model and rebuying it.
Maybe there is a problem of installing that model.

When I used hit died Gui it was not working.So I removed it game again bought it.

Yup, I’ve included the code in the screenshot, at line 41.


Also please keep in mind to look throughout devforum for answers before posting.

Have you looked into this answer?

It specifies you need to pcall the function or it can result in issues.

I read through the post but I don’t understand what “pcalling” means…?
Do you mind giving me an example of it?

You don’t need to pcall. Using pcall will not fix the issue. The only thing that pcall will do is catch any errors that might occur so you can appropriately handle them.

To the op, what place id are you trying to create a reserved server for? IIRC it has to be the same place as the place you’re calling it from.

Please also have a look at this to see if it covers any of ur issues??


And also please look if the PlaceID matches the place the users are located at.

I have stated that I’ve look through it in my post already. Also tried to copy and paste their codes into a new script, still not working, the output is the same.

Have you tried changing PlaceId in your code to: game.PlaceId??

Yes, that works for some reason, but it teleports me back to the same game.

Is the place you’re trying to teleport to under the same universe?

1 Like

@grilme99, Its a reservedserver within the place.

my bad, yes, as @grilme99 question asks is it?

Nope, I tried adding it but it doesn’t allow me to.

It will need to be under the same universe to work…

I’m just making sure, are you familiar with universes? To use reserved server it had to be with a place under the same universe as the place you’re using it from.

1 Like

To add onto this,
to have a game under the same universe you need to open Game Explorer > Right click places > Add new place > Name it and everything, then upload your game to that.

Or copy and paste everything into that place.

1 Like