Turning on/off HttpService from Game Settings does nothing

Turning on/off “Allow HTTP Requests” from the Game Settings menu found inside the Studio Home tab does not actually toggle HttpService on/off.

Steps to Reproduce Bug

  1. Open Roblox Studio
  2. Create a new baseplate
  3. Go to the Home tab
  4. Select the “Game Settings” menu followed by “Security”
  5. Attempt to turn on “Allow HTTP Requests”
  6. Publish the game

After doing the above steps, check to see if HttpService is actually turned on by printing the HttpEnabled value of HttpService from the Studio command bar. The value printed out is false.

I’ve had to create a detailed tutorial for my community to ensure that they can still use my stuff as it requires HttpService. The link is here if anyone wants to share a ready made solution to their friends and communities.

Edit: I am aware this has been posted before, but it was posted on development support by a basic user. I requested that post to be moved to bug reports, but no one did that. So, I’ve created it here as I myself run into this issue constantly.

Edit 2: I’m not entirely sure if this bug affects everyone, so I’m going to post a poll below. Feel free to answer if this bug affects you or not.

  • Yes, this bug affects me.
  • No, this bug does not affect me.

0 voters

1 Like

That’s very strange. What OS are you on? What version of Studio are you using? Is this the only setting change that doesn’t apply for you (ie: do Experimental Mode and all of the Avatar settings work)?

Hey there,

I’m using Windows 10 Enterprise, using the latest version of Studio (as it force updates anyways), and yes, every other setting seems to work perfectly fine.

It’s only the HTTP requests setting which fails me.

Ok. Just to make sure I’m checking correctly, can you send me a video of what you’re doing, as well as the result you’re seeing?

Hey there,

Just went to record a quick gif, upon doing so it seems to be working for my Studio. Not sure if that’s due to an update or clearing AppData, but it works.

However, my community have reported this issue to us as our service didn’t work without HttpService.

So, I’m not too sure how I’d be able to reproduce the issue myself on my end. I’ve asked others to report the issue to Roblox.

Hopefully the people who voted “Yes, this bug affects me” can post their repoductions here.