TweenService:Create failed because Instance is null

The error in the output was what was said above. Code:

1 Like

I still need help. Anyone?

RNuke is not an instance, its a position
you can change it to local RNuke = game.Workspace.Nuke

1 Like

What exactly is RNuke? It’s confusing as to what it is :face_with_spiral_eyes:

im dumb bro im actually dumb


It’s also not a position, he tried to get the “position” of a table full of children.

1 Like

RNuke is a model of a nuke

@cocacolapepsicocacol what do you mean by instance?

just remove the :GetChildren().Position and not tween the Position property because that doesn’t work

oh my god you cant tween model.Position because model doesnt have model.Position!

1 Like

it is not a model its a position because of the .Position at the end

I want to tween the nuke but you can’t tween a model so I tried getting all the parts in the nuke and tweening them

if the op says its a model then it’s a model…

Yes that’s why I didn’t do it, I got all the parts inside the model which is why I used :GetChildren()

did you know that models have something called PrimaryPart? Woo!

Think about it like a weld for all the parts of your model… Set one as the PrimaryPart and tween that position…

weld the parts together then tween the part that the others are welded to

Instances are any object that you can see in the Explorer window.

No I don’t know that


Meant to reply to @Opxtical

Uh and I’m sure that’s how PrimaryPart works. I don’t build.

@T3_MasterGamer @cocacolapepsicocacol
Alright I’ll try and fix it soon

How would I make a part a primary part?