Two weeks of work vanished?

This is a team create bug.

Let me tell a little story first...

I know that getting disconnected from team create sessions is infamous for undoing up to hours of work, but this just raised the roof. I was working on my game’s new dungeon update a bit ago when I went to eat. After coming back, it said I had disconnected, so I wasn’t really affected and clicked reconnect. However, that all changed when it reconnected. Upon loading in, I went to my area of work and noticed that pretty much everything was reset to the way it was a week ago. Without hesitation, I headed to the version history to find a solution… nothing. It appears that the versions saved from this past week only have minor differences compared to the first version. In some versions, the dungeon was completely missing? It made no sense. How could I publish an update, test it in-game, and see everything the way it was in studio every day of the week and not have it saved in the version history? My next best option was to check the auto saves and recent saves… same issues pop up. Missing things all over. So what option do I have left? Forget about one of the best work weeks I had and just spend another week doing the exact same thing? Of course, I’ll do anything for the game’s completion. And when I say week, I mean literally every second of free time I have… I work too much. I’m posting this because this is a completely new version of this problem to my knowledge. I don’t want anyone else to lose what I did, and I hope someone in a position to help fix this reads this.

Now that I'm done with that giant block of annoying sentences, here's other things I should mention:

  • Before this happened, my friend and I were getting disconnected and reconnecting to the studio at the same time very frequently (started about five days ago)
  • I was alone in team create when this happened
  • The game has been in team create since its creation
  • My studio autosaves folder says that it was last modified when it should have saved my work, but there is no save file corresponding to the given date. I tried every viewing option in the file explorer and checked the crevices for any sign of a file, but I found nothing
  • When joining an actual game server, it has some elements from the lost update, while the studio has nothing from the lost update
  • I’m not the only one with this issue, I’ve read and heard about this happening all over in team create, including past partners

This adds about two weeks to the update’s release due to the timing of this incident conflicting with my school schedule. I really hope someone finds out about the cause of this.

P.S. - I did hit publish every time I left my chair, so that may have had something to do with it.
Also, sorry for the chunkiness of this post.


I’ve had issues with progress loss in team create as well, which is why I never use it if I don’t absolutely have to. I’ve also since started saving a local copy of the game after getting a good chunk of work done.


If you published it at any point, it has a version history rollback.

1 Like

It should have, but they’re all missing what I actually did that day – they’re basically very slight differences than no update. In fact, there is nothing at all from today, even though I worked all day while publishing and testing with friends here and there.

1 Like

Also, this has been happening every time I try to save:

Hi, Chrythm,

I am really very sorry to hear the bad news that you have lost two weeks of work. Could you please help upload the recent log files from your disk for us to analyze?

The “Server Save Failure” error seems to mean that the game file may be too big, and fails to be uploaded to Web data store. And if possible, would you mind sharing me a copy of your game in private? Recently, we received some other large sample games from developers, causing some others issues like out of memory usage, and etc. We are trying to improve them now. And this is the first time to see such consistent error messages of “Server Safe Failure”. So, it would be very helpful for us to analyze if possible.

Thank you so much for your helps!
Best Regards,


Sorry to hear about that, same thing is happened to me so I decided to NOT trust Roblox and Always save an Offline Copy in case something goes wrong. This goes for everything a Game, a Model, a Script, you name it.

What I suggest you do is work in a non TeamCreate place and then you update the TeamCreate place so that it’s not so irritating while working on your game, and Remember to Save Often.


Hi, Chrythm,

Just reread your post this morning, and some question.

1: For this recent week, did you and your members always work on the game?

The reason I am asking is because if no active developer is connected to TeamCreate server, it would be reclaimed by the system. And next time, if anyone reconnects, a new TeamCreate server will be allocated, grabbing latest version from Web. And during this week if it happened, when reconnecting, you should have noticed the change lost problem. If the lost changes were still available recently when reconnecting TeamCreate, that would be very strange for me.

2: You mentioned that when joining the actual game server, it has some elements from the lost update. While Studio does not.
This also seems rather strange. Just checked my leader, the actual game server is currently grabbing the latest published version from Web, which should be the same to the Studio team create model.

So, some more info would be helpful for us to analyze, like recent log files, roughly when did you find the change lost issue, the place info. We will try to investigate further:-)

I don’t have a disk drive on this computer, if that is where disc logs go.

Most of the time I was working alone, but my friend would often join in and help every few days or so. I did work at least once a day.

In-game differences disappeared shortly after, but while it lasted, it was a version of the game that was between the full lost update and the earliest version of the update. I’ve been working on it recently and getting a descent bit redone, haven’t had any problems since yesterday. The place size at the moment is 23,755KB.

And for anything in specific that’s useful, I’ll do my best to provide information.

EDIT: Most of my work from last night was deleted from the game again, despite having uploaded it multiple times before I got off. However, this time I have a local copy to fall back on. Also, it appears that I’m unable to save any changes to the local file from last night. It just says this:

After choosing a different name for the file to save as, it replaced the file I was editing and trying to upload to the game. The replaced file is called Place1 and the file size is one fourth of the actual game.

I just published it with success, but the local file is corrupted and has many missing objects of the game now?

Publishing right now takes a few seconds and works fine

Hi, Chrythm,

You mentioned after having uploaded it multiple times and your work from last night was deleted from game again. Did you check the version history changes when successfully uploading/publishing your game? You know, for team create game, you can see the version history for specific game place from roblox website. Once published succeeds, refresh web page and you will see a new version entry. And you can also choose to revert to some specific version in webpage. By default, TC server tries to auto publish new version every 5 minutes if any change available.

Btw, you mentioned that no disk drive on this computer? You know by default the Log & AutoSave folders sit on the same drive. On my machine, the default auto save is “C:\Users\xxxx\Documents\ROBLOX\AutoSaves” , and log folder is “C:\Users\xxxx\AppData\Local\Roblox\logs”, could you try to find the log file, you know, the log files would be helpful for us to analyze:-)

I saw nothing from today in the version history until the publication was successful, and I couldn’t find any files other than place files if that’s what you’re looking for.

On Windows, put %LOCALAPPDATA%\Roblox\logs into the file explorer address bar, and it would jump to log folder. If successful, please zip the content and share with us:-)


I have all objects visible too.

EDIT: Whoops, wrong search bar. .zip files are not supported here though.

You’ll have to upload them to Google Drive/Dropbox/etc and link that here

1 Like

Not to search %LOCALAPPDATA%\Roblox\logs in explorer, you need to put it in the address like below:-)

Or press “Win-R”, and put %LOCALAPPDATA%\Roblox\logs like below.

Once zip them, please upload them to Google Drive, and send me the shared link in private:-)

I have a similar problem where you would open a script in TC, not have the “____ Editing” appear when you are writing the script and close it to see it doesn’t register what you type.

I think they mean copy them and paste them somewhere else, then zip them and upload that zipped file to Google drive.

Don’t worry, I got it through using a DM.