UGC Items Name/Description can't be Configured

Not being able to config your UGC item is annoying… this needs a fix


very important update on this: my team & i are currently losing hundreds (maybe even thousands) of dollars because of this and we would much appreciate if the issue was fixed so we could continue generating revenue for both the roblox company and for our development team thank you


Yup, getting this issue too, and I can’t put the items that have been uploaded onsale.

1 Like

I am having this problem as well. I cannot get to the configure page to even put my items on-sale, nevermind changing the title/description.

How does this work, is there any more details like do I open console on the item page, since I tried this and had no luck

Having this issue as well, can’t configure uploaded UGC items to my group.

Been a issue of mine for over 2 months now, hurting me a lot. Roblox is yet to fix this huge bug preventing us from making money. Can’t configure any of the newly uploaded group assets. Just gives me this page.

1 Like

genuinely such a shame that so much revenue is being lost on both the developer’s and (more importantly) roblox’s end. i really hope that this bug gets fixed soon so that roblox as a corporation can continue to generate tons revenue for themselves (all im sayin is that money’s very important and UGC generates a bunch of money… you feel me rblx staff?)


Can’t believe this issue is still not solved in over 2 months.


Having the same issue it’s annoying asf

I can’t put my UGC onsale too. That is pretty annoying

Pretty sure they just fixed it !

I can now configure my items :slight_smile:

after about two months of waiting, this bug has finally been fixed on my end. hope that everyone else reading this thread has it resolved for them as well!

This issue was solved on my end as of yesterday morning. Finally 2 months ridiculous.

Also love that crown btw let me know the name of it when you release it I will buy it :+1: