UI SFX not destroying with Sound Destroy()


I tried using PlayLocalSound, and tried Sound.Destroy as well as Sound:Destroy()

Code Not Working:

I do bring it in as a string, I wonder if that has something to do with it. It seems to play fine with the PlayLocalSound(sound)

Could you try adding a sound.Loaded:Wait() before the SoundService:PlayLocalSound(sound) line

if that doesn’t work try game.Debris:AddItem(sound,0) instead of sound:Destroy


still stacking them like i wish i could stack my robux

My alternative is to not use a Module Script to call the PlayLocalSound(sound), but it could be just buggy. Idk.

I believe this is an engine bug: PlayLocalSound() issues - e.g. Ended not firing - engine bug or incorrect usage? Alternatives for playing sounds locally?

I have reported it and so far ROBLOX have said they can replicate the issue.

1 Like

Was your alternative to just use the original sound:Play()?

1 Like

I assume that would work the same if you did it from a LocalScript. I also assume that was the original method for playing sounds locally, which is why I can’t find any bug reports/reported issues in the forums (relating to PlayLocalSound) apart from your post and another one.

1 Like