UI Sizing Problems

I am having problems with sizing my UI. When I size it in studio, it fills the entire screen, then when I launch the actual game, it is to small. I will leave a picture below on what it looks like in studio and in the actual game.

In game:

In Studio:

1 Like

Use the scale property instead of offset on the size of gui objects.

1 Like

What do you mean? How do you do this?

Set scale to 1 and offset to 0 for it to fill up the whole screen.

It is already set to that.

It looks like you have some kind of constraint on it. Remove that constraint.

I have removed the constraint, should it work now?

You have to check for yourself. Use this button to see what the gui looks like on different devices:

Thank you so much. Now it works!

I suggest using this plugin.

This will auto-scale the size and positions to fit the screen.

I used this and this is what made it not work.

For cases where you want the GUI to fill the entire screen, you should be using the usual scale property set to UIAspectRatioConstraints scale GUIs according to a ratio based on the size of the GUI it was prior to adding a constraint - you should be using this only if you want to guarantee the same UI size on a different ratio scale, not for covering the entire screen.

Personally, I would make the parent frame (the one with the flag) with no constraints, then I’d put everything that is inside in another frame, then I’d constraint that frame with a anchor point of 0.5,0.5 and position of 0.5,0,0.5,0, hope that helps!

1 Like