UI Text randomly flashing

Any updates on this? We get reports from mobile users about glitchy text on our game Seaboard City, very often. Game UI and Core UI have full labels or portions of it randomly disappear or reappear.

Device: iPhone 13



This is still an issue. Just converted all of our UI windows to use their own ScreenGui rather than all being under one primary ScreenGui, in hopes that it would address this (it did not!).

Flickering happens on both 2D and 3D GUI.


I am also having this issue. (Noted after adding UIStroke to my UI). It is occurring on the latest iPhone models at minimum.



I’ve also been experiencing this lately! Every time I load in on a mobile device, the screen flickers exactly like in @wravager’s video. I believe it may have something to do with how much is being rendered at once, because in the corner of the map, the flickering doesn’t happen as often. When in the middle of the map, it will always flicker.


Just here to report SAME on one of our games on mobile. Pretty much identical symptoms as everyone else reports here.

Hi, this post that might explain the issue you guys are encountering:

We might need a longer time to resolve our internal tech limit for this, so could you guys check against those development suggestions in the post to see if any of them could apply?


I believe a lot of these suggestions would help reduce this issue, however there is one thing I’d really like to see added and I would really appreciate if you could look into it.

As of now, you can set a max visibility distance on BillboardGuis. However, I find that I tend to use a lot more SurfaceGuis than BillboardGuis on parts in the workspace. If there is a way to add this max distance property to SurfaceGuis (when used in workspace on parts), I think it would really help resolve this issue and may even improve a game’s performance. I tend to find that having many SurfaceGuis in my game, even when they are not near the player, can cause this text flickering issue as well a performance drop.


this could be possibly related to the recent dangerous ui flashing issue, where if you join the game the whole screen starts glitching alot, its actually very bad for epileptic people (like meeee!)…

the link: Extremely Dangerous Flashing UI Issues

1 Like

I have also experienced this but not in mobile, but in mac laptop… the text was glitching for a few seconds upon joining then stopped…
Also this happens in looking in multiple places, and a performance drop was detected…
and i’m in beta


(had to send it in pic because i can’t send video)


Same. My observations in the game Wravager showed (I was using an iPhone 13):
It occurs on the loading screen, stops momentarily after the play button appears, then reappears without subsiding after hitting play.
The crafting button is completely blank.
I wonder if using a font besides Luckiest Guy can be a temporary fix or at least make things more legible…

Still an occurring issue/bug on mobile; used a Pixel 6 and text was flickering like the examples given above.

1 Like

Hello I am having this issue!
the letters are spaced out and also the texts doesnt even show and I havent coded it like that

What it shows:

What it suppose to be:

This is mobile yes.

Game: Swinging Simulator⚔️ - Roblox

It just released and now its going to die cause of this problem? we spent 3 months developing this and now its gone to waste? we are already on like 69% like ratio cause of this problem

Please fix asap cause this is important.

I can reproduce this on my iPad. It’s rare, but it happens, it seems like it might be iOS specific?

edit: yep, it’s iOS specific.






And of course I could reproduce on my iPhone/Pad

This is easy to fix, just go to more and click on a button that opens up a web page in the app, then click out of it. Should be fixed.

I’ve seen this bug a lot of times before, especially on mobile, and I’ve been keeping track on it’s behavior. So far, this is what I know:

  1. The glitch’s cause is sometimes because of a “text overload” (which means that there’s too much text on a surface/screen UI that it cant really write it. Not sure how to explain it properly.)

  2. Another cause may be because the device is trying to save on performance. I.E. Running QSERF on the latest iPad might result in it lagging and therefore trying to save resources.

  3. Font/Text Index? I’ve heard of this cause before but I don’t have much information about it so feel free to explain to me what it is.

For people who are not in-game and instead is on the app experiencing this glitch, go to the other section of the app and click on groups (or any other button that leads to a webpage), then close out of it and return back. It should be fixed.

Has this been resolved?? It’s happening to me on my PC (NVIDIA GeForce GTX 970)

1 Like

I just fixed it!! Turns out its your screen resolution causing the issue, I lowered my resolution to 2560x1600 and it fixed it!

Hi @Qalus, I was wondering what game you are showing a screen capture of? Thanks!

1 Like

i Literally just said on my post that it was on mac

1 Like

This issue has been happening to my games for months, mainly on mobile, but recently started occurring on my PC. Very strange and frustrating!