Unable to code properly since yesterday due to forced expressive output window

Feature in question:

I’ve had to disable the expressive output window ever since it was introduced due to lag issues that I experience with it and printing large tables. Unfortunately ever since an update released some time yesterday, I seem to be unable to switch back to the old output behavior. It doesn’t appear in my beta features list anymore and I can’t find a setting for it in studio settings.

I don’t have tables expanded by default but my studio still freezes up whenever printing the collapsed tables - which happens very often and I’d rather not have to go through the whole game and remove all of these prints, they’re there for a reason. Now I find myself unable to properly debug my game as I’m constantly printing tables and the freezing, even though it’s a short burst, gets pretty frustrating.

These tables aren’t even especially large, but there are a lot of tables within tables.

The best way I can replicate this issue myself is by actually printing out a pretty sizeable table, but I’m not sure if everyone else experiences the lag here in the same way. The code below creates a much, much larger table than the one printing above, but I experience practically the same amount of lag without even expanding the table:

local t = {};

for i = 1,500 do 
	t[i] = {table.create(i, "This is very laggy.")};

My specs

Operating System: Windows 10 Home 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
System Manufacturer: Hewlett-Packard
System Model: HP ENVY 17 Notebook PC
BIOS: F.57 (type: UEFI)
Processor: Intel(R) Core™ i7-5500U CPU @ 2.40GHz (4 CPUs), ~2.4GHz
Memory: 12288MB RAM
Available OS Memory: 12210MB RAM
Graphics Card: NVIDIA GeForce GTX 850M

I only have this problem with the new output window, and the freezes don’t happen for an incredibly long time so I’m not sure if dump files will be of much use. The process itself doesn’t usually register as “Not Responding” unless I spam click studio while the lag occurs. I’ll include the logs anyways just in case.

1 Like

@Scriptos We’ve re-enabled “Log Mode” which disables table printing. This option can be enabled via the 3-dot dropdown in the top right.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.