Unable to delete drafts

i cannot delete drafts of committed scripts & i cannot commit them - they are stuck there permanently and persist after restarting studio. this is very annoying

Expected behavior

i want to delete my drafts after i delete the script


Have you tried right clicking on them and discarding?

That’s a stupid question.

Could you provide the current studio version, and a log file? Also, a video of the issue would help too.


Haven’t had to get studio version or logs in a while and I don’t really wanna dig around studios files as it’s a pain to do on Mac, but it started over the past week. Here’s a video:\

System specs:

Screenshot 2023-11-19 at 11.40.28

What about restoring and then discarding? Maybe try re-installing studio.


If you don’t want to listen to other people, and try what they say, then there is no reason to create this topic. The devforum is an community, so if you want to get this issue fixed, then please try what they say.

1 Like

This is clearly not intended behaviour, and until recently it worked as expected, The bug is valid and ive now provided appropriate repro (since for some reason the ticket wizard didn’t ask for that anymore).

I’m not even going to entertain the idea of some ridiculous workaround, as that would inconvenience me more than the bug itself.

Play stupid games, win stupid prizes

Thanks for the report! We’ll follow up when there’s any update on the issue.

1 Like

This looks similar to this issue

Unfortunately in some cases (sometimes due to upgrades, sometimes due to virus checkers, sometimes ???) the Drafts lose their proper access rights to the local Draft files and cannot be deleted / modified.

We have never been able to repro this in house but the only currently known workaround is to make sure those drafts are not locked and owned by you.

The drafts live in the /Users/<your user name>/Documents/Roblox/Sandbox/<placeid>/<userid>/drafts folder, likely is the folder that you last modified in the Sandbox folder.

Currently the best advice I can offer is to make sure in the drafts folders all the files are owned and writable by your local user.

Deleting these files should also get rid of the drafts.

Not sure how useful this information is, but this issue constantly occurred for around the week where I reported this in that one studio version and hasn’t occurred since - However I still have some stuck drafts from the bug and if it would be useful I can try to assist any investigations

This still occurs and to discard drafts for deleted scripts you have to restore the draft and delete the script

@LuaBearyGood – thank you for the info, it sounds like this might have been indeed an installer issue.

As for the stuck drafts, currently the best method to fix this is the one I describe above. Please let me know if that worked for you.