Unable to Download - Roblox was not able to update

Pretty self explanatory, this happens when I try to open roblox.
I updated to MacOS Ventura 13.3.1 (because my GPU kept artifacting when playing) a few hours ago and it doesn’t work after that.

Things I’ve tried so far:
Restart
Reinstall
Clear Logs
Clear Cache

I don’t think roblox is down (status.roblox.com)…

Thanks in advance

image


(same with studio)

9 Likes

I have no clue why, but it works when I use my phone’s hotspot instead of my home wifi.

5 Likes

I’m also experiencing this issue. I tried to post a bug report but I’m not able to post in that section.
It would be nice if we could get this thread moved into the right section. @FarazTheGreat

I’m also running macOS Venture 13.3.1 but with an Apple M1 Max Chip.
I’m using Safari Version 16.4 (18615.1.26.11.23)

This problem started for me today (April 15th, 2023) around 8am Pacific Time.
Roblox & Studio were launching as expected hours prior (April 14, 2023) around 10:30pm Pacific Time.

I’m getting the same error messages as the OP and it occurs 100% of the time I attempt to launch Roblox or Roblox Studio, either from Finder > Applications, Website > Any Game > Play, or via … > Edit for studio.

I’ve uninstalled & reinstalled Roblox & Studio 4 times throughout the day today, each time clearing any & all files from:

  • ~/Library
  • ~/Library/Caches
  • ~/Library/Logs
  • ~/Library/Preferences
  • ~/Library/WebKit
  • ~/Library/Saved Application State

The issue still persists. This issue is also happening on my laptop which runs the same OS and Safari version as written above. I’ve also uninstalled & reinstalled 4 times on that device like above.

Log Files

https://devforum.roblox.com/t/unable-to-download-roblox-studio-was-not-able-to-update-macos/2299437


6 Likes

Roblox is no longer down. It’s working now.