Unable to enable/disable HTTP requests

A user came to me with the question of why his game won’t allow HTTP requests.
I haven’t touched studio for a bit and I checked with one of my old places to see if this was just him but I am not able either to switch from “off” to “on”.
It just reverts back for some reason and doesn’t say anything.
Is there something I am missing here?
I am using Windows.

Note: I also tried with a empty baseplate the other way around, same result.

6 Likes

Did he enable HTTP service in game settings?

2 Likes

Thats what keeps resetting.
Referring to this image;

Well, it should be changed to a bug report, if it wont stay on.

Moved.

Ok, so I looked into this and I figured that it doesn’t save what you select.

Problem #1
When I first opened the settings (the game was httpenabled prior to the update), it showed that it was disabled. I know this is false because my httpservice seems to work fine.
image

Problem #2
It fails to update what you want it to be. Here’s a gif.
https://i.gyazo.com/a1281fc22385ca466bfe057e64f618a8.mp4

completely new place
https://i.gyazo.com/11a63721b2f7152f784a2b4550983da2.mp4
is it on by default or off?

So AFAIK, new games can’t enable httpservice and current games with httpservice enabled can’t disable, unless the issue is only for me.

@OP look into this, then maybe change the title of this to “Unable to enable/disable HTTP requests” if you have the same issue.

2 Likes

Yeah that’s pretty much what i’ve said on the follow up, changed the title.

2 Likes

It wasn’t as clear for me, sorry! I’ve provided a gif of it for others to see though!

1 Like

Hi there,

Thank you for reporting this bug to us. Our engineering team will be looking into it. :grin:

Regards,
Quentisaurus

4 Likes

The display seems to be backwards (showing off when it’s on, and vice versa) when the menu is first opened. Changing the option to one and then back will change the value correctly (It will still display backwards when the menu is opened again, but the value will save). We’re looking into a fix now.

5 Likes

Same problem here, but its ‘On’ but not really on and cant switch, same as you guys.

1 Like

Switch to off, then back to on.
When you re-open, it’ll show as off, but it’ll be on.

1 Like

Also getting this problem. I can’t enable HttpService no matter which setting I select on the menu.

3 Likes

Temp fix, game.HttpService.HttpEnabled=true <- Command Bar (Unless you already have done this to get around it.)

I’m very curious, @Silent137, not to be rude or anything, but is there something that is causing the delay in fixing this bug? From my understanding, it’s only a simple flip, but I’m curious if there’s anything involved.

CS major, I’d wanna know :stuck_out_tongue:

In all likelyhood, it will be delays because patching to live environment.
You will learn all updates get slowed down once you put them in a business. I am currently sitting on tickets that are a month old in my company, where the work has been done but is awaiting the next release.

I don’t quite get it. Is it that they push the update alongside other patches/updates (like every wednesday or whatever maintenance days)?

I can’t say for certain what happens at Roblox, but in the company I work for only super-high priority tickets (The whole company is exploding and angry customers are grabbing pitchforks) will get patched into live environments. Since Roblox has a fast release schedule and this is only a display issue (No internal bad things are happening), I imagine it will go in with the weekly patches.

Might’ve been a topic not related to the main topic, but thanks for this! You learn something new everyday.

Due to the nature of the original change, we had to ship a new version to fix it. That fix should be live later today.

4 Likes