Unable to expand explorer while in debug mode (bug?)

The Issue
When debugging a script I’m unable to expand anything in the Explorer window (screenshots below). When I do try to expand something (e.g. Workspace), they disappear.

Note: I have been able to replicate this issue across three different computers (Windows) and two different Roblox accounts. Two of the computers I tried this on had never had Roblox Studio installed on them and were completely fresh installs. One computer had never even had Roblox on it and was a completely fresh install.

Studio Version: 0.570.0.5700563 (64bit)

General Steps to Reproduce
Set a debug point in a script, run the game, interact with part that has script, once the code stops at debug point go to Explorer and try to expand Workspace or any other folder/grouped item. It should disappear.

Screenshot 1 - The code has stopped and on the right side in the Explorer you can see many items that can be expanded by the carrot. Workspace and Players being the first two

Screenshot 2 - You can see on the right side in the explorer that all the items that I could have expanded are gone. I went to each one, clicked them to try and expand them, and they are gone from view.

Detailed Steps to Reproduce

  1. Launch Roblox Studio
  2. New → Baseplate
  3. Insert → Part - > Block
  4. Set part to Anchored
  5. Add a script to the Part
  6. Delete default text in script.
  7. Add the kill script from the Deadly Lava tutorial
local lava = script.Parent

local function kill(otherPart)
    local partParent = otherPart.Parent
    local humanoid = partParent:FindFirstChild("Humanoid")
    if humanoid then
        humanoid.Health = 0

  1. Set breakpoint on line 4
  2. Test → Play
  3. Walk into the part to trigger the script and the break
  4. With the break triggered you’ll be on the script screen. Look at the Explorer and select the triangle/arrow next to Workspace. For me, it disappears.

Continue with steps to try and get Workspace to actually appear correctly in debug.
12. Resume until you respawn (could be multiple times since the code doesn’t have a debounce)
13. Switch to Baseplate tab
14. Test → Current: Server to switch back to player
15. Walk over part
16. Now on the debug screen look over at Workspace. There is a chance you’ll now see that the Workspace is there and is expanded. You can click the triangle/arrow next to it over rand over and the children will show up.

Attempted Troubleshooting Steps
As directed by a Roblox Staff member I tried these debugging steps.

  1. Clear your Roblox Http cache. This can be done by manually deleting all files in one of these two folders, depending on your operating system:
    Windows: %temp%\Roblox\http
    Mac OS: $TMPDIR/Roblox/http
  2. Reset Roblox App Data
    This won’t reset the settings but the app data to potentially fix the error you are facing. You can following the given steps to do the same.
    A) Open Run by Win + R.
    B) Type %LocalAppdata%\Roblox and click Ok.
    C) There you need to delete Download, ClientSettings, and LocalStorage folders.
  3. Clear Registry
    A) In the Start menu, search for regedit and open it
    B) Navigate to HKEY_CURRENT_USER\SOFTWARE\Roblox Corporation
    C) Right-click on the key and select Delete.
  4. Try these possible fixes from this article
  5. Delete the Roblox Folder using this guide

launching Studio with plugins disabled.
In case you don’t know how, check this guide

1 Like

Submit this to the group @Bug-Support for further investigation.

It seems like a bug. I tried to reproduce on my system and couldn’t reproduce it.

Have you tried basic troubleshooting such as reinstalling Roblox Studio and updating your OS and drivers?

1 Like

Thank you for the suggestion. I have sent them a message with all of the details and hope they are able to determine root cause and solution.

Thanks for letting me know you were unable to reproduce it. I just did an uninstall/re-install but it still is happening. I’ll try to keep going down this path knowing it may be isolated to me. I’ll uninstall plugins, update drivers, etc. and see if I can resolve it.

Closing this thread as this category is not meant for bug reports!

We worked with the OP in filing a bug report internally for his issue, it can be found here:

Thanks for understanding!