Unable to initiate creation of new servers

connection

#1

Not 100% sure that this is a web bug, but it’s my best guess.

When I attempt to join a game with now open servers, my client is stuck on “Waiting for an available server… Retrying”
This happens whenever I join any empty game. It seems to be failing to create a server for me to connect to. I have tried on multiple empty games, and the issue is consistent between them all.
I am able to connect normally to populated games/servers.

I have tried disabling my antivirus software and firewalls, but it didn’t help.

I have been away from my PC for a week, but when I returned and logged on to my place on 14th Oct 2017 the issue started. When I was playing on the 8th Oct, everything was working normally.

From ~1st October (unsure of the exact date) I noticed that when I connected to empty games it was retrying up to 4 times before connecting to a new server, but I assumed it was just an update to the client. If this wasn’t an intended feature it may also be part of the problem.

I would also like to say that my internet has been acting strangely lately and that might be the issue, and I will be testing on another connection later today. I don’t think my connection could be the reason though, as I can join populated games normally.


#2

Sometimes happens to me until I disconnect and connect back to my internet. Haven’t gone to the 200s though, because it’ll kick me and tell me that I lost connection and need to rejoin after around 12 tries.


#3

I have tried reconnecting to my internet, and have tested with another connection. Neither worked.
I have also tried reinstalling roblox twice, but that didn’t work either.
This is causing me problems as my main project is meant to release very soon, and I can’t test online without someone else creating the server for me.


#4

I am bumping this topic because I have useful info about it and it is a problem that still occurs to this day:

I experienced this problem a month ago and apparently, it can still occur to other players, what I did to fix it is a few things:
Let’s start with the things that did not help me: reconnecting my network, reinstalling Roblox, reinstalling Roblox studio and publishing my place again, moving my place to another game.

Now let’s talk about what did help me and worked: After joining the game and waiting for an available server, quickly rejoin the game and wait a few seconds, then it will open.
Now, this is very bad because nobody is going to rejoin your game now or even knows about this technique which renders it useless. (check the paragraph below for the real solution)

this problem mostly occurs when your game needs to load a massive amount of parts/unions/terrain, to solve that you will have to create universal servers through configure places and configure game, then teleport between these servers which will make it automatically go to the other place without any disturbance nor waiting for an available server, hope it helped anyone who experienced this issue!


#5

Hi, I had the exact same problem a few months ago in my game, which was caused by a big number of huge wedge parts which I used for the terrain.
My solution is to turn those triangles into little parts with meshes inside to make them look as big as needed, and when the player gets close to those mesh triangles, they are converted locally into real parts so he’s able to collide with them.
The only downside of this approach are the lag spikes which happen sometimes when a lot of triangles are loaded on client, but nonetheless, this allowed me to avoid splitting my game into several places.
I’ve heard somewhere on the forums that Roblox is planning to fix this issue eventually, but for now we need workarounds, such as mine.


#6

This problem fixed itself by magic for me, but for me it was happening on every game, and effectively stopped me being able to connect to any empty games. So afaik it was a problem with roblox and not with any game in particular. It also happened in baseplate games.


#7

Have had this issue the whole day. I can join servers with other people in it but I can’t create a new server and it gets stuck on Waiting for Available Server. I tried resetting my WiFi but it still doesn’t work!


#8

This is a Roblox wide bug with big games

I think it’s if you use multiple :GetService() calls but I’m not sure
Other things I’ve noticed about the loading system:

Putting LocalScripts in ReplicatedFirst will run even before the loading screen is removed
All scripts are compiled before joining a server
The server has to actually load on Roblox’s side


#9

I’m still experiencing this issue to this very day. I find it interesting that it happens at my testing site but not at the live game.

Could it be that there are server tiers based on a game’s popularity?


#10

Bumping this because I’m having this issue as well at the moment all of a sudden, was joining games with no issue yesterday, could create new servers easily. Today after waking up, all of a sudden my client is unable to create a new server in any game.

This includes my own games as well, when I join a server with someone inside, I can join in. However when I attempt to start my own server ( by private server or on my testplace ), it will wait forever for an available server.

Simply put, I can join servers, but I can’t start new ones.

I’ve tried reinstalling, connecting to different routers, creating and using a new accounts, restarting my laptop, running on different browsers etc, issue still persisted.

It is friday where I am and I remember my game Rebuild Your Own Mech along with other smaller games going through a ROBLOXCRITICAL issue before twice on this same day of the week, where datastores and httpservice failed on us completely for smaller games. It was only running for bigger games so I would suspect there are server tiers based on game’s popularity as @devSparkle mentioned, which is understandable. I would prioritize based off popularity in descending order as well if I had limited attention to a number of games in my business.

EDIT : Issue is fixed for me now – 10:30 EST timezone :clock1030:


#11

image

I’ve left this for ages sometimes and nothing has happened, other times it only takes a little while.
Currently the only fix is to join an existing server which of course doesn’t have this problem because a server is already created, but that isn’t helpful for people joining new empty games.
Seems Team Creates are also suffering from creating servers because it takes about 10 attempts for you to finally get into them.

My testing place is basically useless at this point, and I have to reply on everything working in studio without being able to properly test everything in game.

Please look into this issue, it is harming my development and player experience significantly.