Unable to join my own game

Hello. I came to a conclusion that this problem is on Roblox’s end, so I’ll post it here.

I’ve been completely unable to connect to one of my places for the last 3 days. When I try to enter, the game window opens normally…


…The problem is, it remains in this state forever, without a slighest sign of loading - the square keeps spinning.
When I check the server list (the game has no players, it’s empty), I usually cannot find any running server, even though the game is supposed to be loading…

…Occasionally, one or more(!) servers can appear, but they are marked as “slow games” and don’t seem to function at all. When I try to quickly rejoin one of them, I get a kick message saying “This game has ended”.

Over time, more and more “slow” servers appear in the list, but I cannot connect to any, so I’m stuck in the situation shown in the first picture (square spinning forever).

It happens always when I try to join my test game, and only there (I don’t experience this in any other places). I have a PC with Windows 7 Home Premium 64bit, my connection speed is 10MB down and 1MB up, enough to smoothly play any Roblox game.

However I’m always able to load and play the game in studio, without any problems (it just takes a minute or so to load, since it’s quite heavy).

I’m wondering if it only happens to me, or globally, also, I don’t know if there is anything I could do to prevent this. Being unable to join my own test place is really a hard obstacle, which stops me from developing effectively. Thanks for help!
Here’s the place: https://www.roblox.com/games/836283840/unnamed

Edit: please try to enter the game above, and tell if it worked.
Edit 2: I moved this to bug reports, since other people also experience it.

3 Likes

I’ve been having this exact same issue specifically with a game I enjoy playing. Other games seem to work fine for me.

Not sure if this is related, but joining friends in the past week usually results in this page as well with a red bar on top that says some sort of number error.

1 Like

I have also been having this issue, but have gotten it to work a few times. Not sure what the problem is.

1 Like

I couldn’t join that game either

Roblox is being slow right now

1 Like

Probably just roblox though this may be considered a client bug, so try putting it there. Thats probably where you will have the best luck.

1 Like

I attempted to join that game and I couldnt load into it either, I have no idea what the issue could be.

Are you using DataStores? Could be related:

1 Like

I couldn’t join the game either.

Yes, I am using Datastores, but they work well when I run the place in studio. Also I don’t get disconnected, I cannot connect at all. I think I’ll post it as a bug report.

Try disabling all DataStore use. Then see if you can at least join the game. If you can, we’ve likely found a DataStore bug.

2 Likes

Disabling everything which used DataStores changed nothing. I forgot to tell, but a week ago I was still able to connect, even though there were no major changes in scripts. Perhaps I should try to upload this to a different place…

Even publishing the game as a different place didn’t help. I’m really out of ideas, but I hope someone looks into this. I’ll post more details if needed.

Edit: After investigating, it seems that removing one of the islands fixes the issue. But the thing is that I cannot keep it removed since it’s the main element of the update I’m preparing. The island alone has well over 7-8k parts, and the entire place has 34k+ parts. Does it mean that the place is too huge for Roblox? The file with it has 21.6 MB.

1 Like

I know this is an old topic, but I’m experiencing the same thing with one of my games and I haven’t found this issue described anywhere else, I’m also getting desperate as it has been doing this for almost half a year with no solutions found.

Here’s all I know from troubleshooting:

  • It is very fickle on whether or not it loads. It may load in 4, it may load in 60, or (most of the time) it doesn’t load at all. Being persistent reloading the page and trying to rejoin can sometimes get it to work, but not with any reasonable reliability.

  • The issue is somewhere in the parts of the game, not scripts. I’ve deleted all the parts, leaving the scripts, and it loads instantly.

  • The issue can be narrowed down to a specific group of parts (if I delete one whole area it works somewhat) but my attempts to narrow it down further have failed (I can’t get it to work by deleting just specific parts within this area).

  • It may be tied to unions, as I’ve found a few broken unions that made the game work semi-reliably once I deleted them, but the fun part is the game completely broke again when I added new models with almost no unions. Deleting the new models afterwards did not make the game load again.

  • This game is not heavy at all. The whole thing comes in at just under 7k parts, and I have built games with more unions, parts, and scripts that all load fine. I have also used many of the assets in the game in other games, and there are never any problems with them.