Unable to join Roblox


A couple of days ago I haven’t been able to join Roblox on my laptop and I’m not sure why.

Device information

  • Device Brand: Asus
  • Operating system: Windows 11
  • System Type: 64 - bit operating system
  • Processor: Intel(R) Pentium(R) Silver N5000 CPU @ 1.10GHz 1.10 GHz

Solutions I’ve tried to far:

  • Updating my laptop
  • Reinstalling Roblox (Multiple times)
  • Resetting my entire laptop (Don’t worry I have everything saved onto a hard drive.)
  • Copying multiple solutions from the internet
  • Swapping browser
  • Creating a brand new account

None of these solutions have worked. :frowning:


I don’t think it is my internet because I am able to join on my iPad and phones using the same WIFI’s.

I don’t think it is my account because I have tried using multiple accounts.

Roblox Studio seems to work prefectly fine but Roblox Player doesn’t and I’m not sure why.

Quick question, are we still able to play Roblox from the browser or do we have to play it from the Microsoft app?

Any help is greatly appreciated thanks!


Is there an error or it just stops working? Might be a computer issue

Please send us a video reference showing the situation.

Is it the “Joining game…” sort of issue with the game loading forever?

Once I click play on Roblox, the dialog that shows Roblox is loading from the website will show and do its thing, then next it’ll open the dialog in the Roblox Player app and say it’s loading and it’ll finish that but once it finishes the game never actually launches and does nothing. I will be posting a video later tonight of what happens.

I do think it’s my laptop but I’m not sure why… my laptops only about 3 years old and its still in good shapes so there shouldn’t be any issues. I don’t think it’ll be any of the settings I have because I’ve factory reset my entire laptop so I should have default settings.

1 Like

I’m unable to send a video right now but I’ll send a video later on tonight.

No, once I click the join game button it’ll do everything like normal. It’ll launch the roblox player app saying it’s loading (the medium roblox player loading rectangle dialog) but it won’t actually launch the game. If you know what I mean

The temporary solution is to use the Roblox app.
This generally has been bugging me a lot lately, too. But since I’m not ranked to have the power to report issues in the #bug-reports , I can’t do anything about it. I just let Roblox handle it since they’re the ones asking to be troubled later by major issues with en masse numbers of people getting to encounter it later on as a sum of users who couldn’t access the report function.

Bug Reporting on Roblox Support also is just lacking especially since you cannot insert/link in the files as per evidence of what is going on.
I’ve been active so much that I am impressed I didn’t have anything like a message from Roblox.

Yeah, I’ll probably just use the app. Is this an issue for you and other users as well or just me?

You can actually send a direct message to bug reports and then they can approve it and post it in the bug report category.

Would you still like a video of what’s happening or do you know think you know what’s happening? If you think you know what is happening do you want to send a video of what happens so others can see and so I can confirm if it’s the issue I’m having or if it’s another issue. I’ll be happy to send a video myself but it won’t be until another 7ish hours.

I am also active on the Devforum and use it a lot and I don’t have access to other categories like feature requests and bug reports. I’ve sent a message to the Devforum group once asking for regular and no response :frowning:

This is also happening for me sometimes, though it has gotten less frequent. Mostly I’ve noticed that issue and the solution while playing the DOORS update for the first time.

I haven’t joined Roblox on my laptop in a wee while because I’ve been using my iPad and phone most of the time but when I came back last night to join Roblox on my laptop it decided not to work. I’ve deleted Roblox but now using the Microsoft app.

1 Like

I might have the same problem, i just made a forum and was looking at others. i have no idea how to fix it. I open it, it shows “starting roblox” closes, doesnt run in the background and thats about it. I used a different pc too which works. The microsoft app sucks in so many ways. Now that i see you reset your laptop with no prevail i will not reset mine. it seems like a waste of time. ALso ironically we are both using windows 11. Are you using insider builds?. i belive thats the problem but i am not too sure.

Haha, I planned to reset my laptop eventually anyways. Nothings really on my laptop apart from apps because everything’s all on my hard drive.

I just prefer the internet version so I can have extensions but, I suppose I’ll have to get use to Microsoft Roblox.

Yeah, I think I do have windows 11 insider version or something.

I belive insider is causing problems for it. Also Imo The microsoft version sucks so bad. If you have multiple screens it doesnt lock your mouse in which is so unbareably annoying. I belive performance is worse, and a lot more stuff. ig it doesnt matter much on a laptop but on a pc its really annoying. Btw still havent solved my problem with roblox

1 Like

idk if i have the same problem like you but roblox store version is only crashing when the pc was booted 5 minutes ago or if i go to stand-by mode and the web player is only running as background process and is crashing with the known “roblox has crashed” message 3 seconds later after a update…

Laptop: Asus ROG G752VL
Operating System: Windows 10 22H2

as you can see there is no roblox game client icon in the taskbar
the only roblox icon u can see is the store client

wait a minute you are not alone with this problem i have the exact one but the store version is crashing when the pc was booted 5 minutes ago

you are not alone with this problem blud (ignore the store version it just works when it was started under 5 minutes ago

1 Like

I factory reset my computer and it fixed. If you have a windows computer, the problem is called the “insider program”. If you sign up it can mess up your comptuer. Since i dont think most are science nerds i will not bored you by reading this. Simple answer is that the “insider program” gives you early access to windows updates, but most applications are not optimized or will work with those updates. Hence why it messes up your computer. They should have a massive warning when signing up rather than just making it seem like its all handy dandy (i know a pretty good amount about computers, and it assumed it was the program from the begginging since it was causing most issues, but if your not into comptuers it is so annoying when you get an issue and cant solve it)

Yeah I’ve figured that its the insider program. Its confusing on how to leave it lol.

1 Like