Unable to join server for specific game

I’m unable to join my game. It gets stuck at Joining Server but in fact the server shuts down before I’m able to join.
At other times it can take up to 15 minutes for the server to actually shutdown. I’ve tried manually shutting down the single instance and all instances through the webpage it doesn’t seem to make a difference. When clicking Play the Roblox icon doesn’t spin and neither does the game name appear. It just goes from Waiting for Server (1) and then counts up a bit and then goes to Joining Server and sits there never to do anything again.

I’m not doing anything special in the game itself. There is a rather expensive feature running in the first few seconds that converts parts to terrain. This has always caused lag on the server in the startup phase but I was never unable to join. The only changes I’ve made recently was 3D modeling a ship and adding it to the game. I then clicked publish and tried joining only to come across this issue. I waited a couple of hours and tried to join again. Only to experience the same issue. This is the same place that I cannot enable Team Create on due to the Gameserver timing out.

I’ve tried publishing the place again in case it was corrupted somehow. This does not resolve the issue. I don’t want to close Studio as I’m not sure if I’ll be able to open it again.

Completely forgot to include a link to the game.

1 Like

Can you allow permission to join, it’s currently private.

1 Like

Made it public. :slightly_smiling_face:

I’m currently seeing the same thing. The logo doesn’t spin and just stays on joining server. There’s something in the game that’s making it very laggy and hard to join.

Exactly, I have a script running that converts parts to terrain. I’ll try disabling it, but the thing is this has never happened in the 30+ times I’ve joined the server after adding it.

Oh my gosh it was the script. That’s strange. It’s literally been on the server for a month and this hasn’t happened. I wonder if they made any changes to the script time out. Its a script that checks for parts in a specific folder and its connected to Heartbeat. So it times out a lot but continues running.

I’ll try to optimize the script a bit more. :frowning: its a bit of a pain so I didn’t want to change it. Thanks for the help :slight_smile:

It’s my pleasure, always here to help developers out :slight_smile:

1 Like

So, I believe I found the issue, it wasn’t my script. (I’m an elite programmer so I was feeling bad about the script that I made over a month ago preventing the server from running) Something weird happened after I tried fixing my script. All my anchored items unanchored themselves and started falling out of the sky.

Come to find out I use @Crazyman32’s auto weld for my newly made boat. Its really convenient. Only its not convenient when you accidentally insert a copy into your Workspace. Thus the server broke. :man_facepalming:

Thanks @ProjectExtraction for the help :slightly_smiling_face:

Ah, that would be the reason why it’s very laggy.

EDIT: nevermind, I see that the terrain script wasn’t your issue now.

I’ve had this in my game all the sudden. I’ve had a few friends say they’ve had it in their game and other games.
It does nothing when I hit ok all it does is disappear.

I think that’s a bit of a separate issue. I didn’t really wanna mark myself as a solution as it felt weird. But I’ll do so just to prevent extra replies. I’d recommend making a thread for the issue that you’re experiencing as to not get it lost in this one.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.