Unable to Log In on iOS with mod warning (Logs out immediately after sign-in)


UPDATE: This is happening due to a moderation warning on my account

On my iPad Pro 12.9 and iPhone 11, when I try to log into the Roblox app, the 2FA window appears and then once I enter my 2FA code, it will immediately sign me out and head back to the login page.

Sometimes it will not ask for a 2FA code, probably since I had just tried to sign in minutes prior and will still log me out after the password was entered.

Here is a video of the exact same problem (this is not my video, but it shows the exact same thing happening)

(Video from me below:) The password was in the box, but the video seems to have blanked it out

This only started today for me, and I have tried uninstalling but the problem still happens.


Typically if a issue would happen in my phone, I would at least wait 30 minutes to an hour before I try again and If I still have trouble logging in, I would at least contact Roblox Support of post on the devforum. I suggest you give that a try. Wait for Roblox to see the issue and fix it within the hour and try again.


Try restarting your devices and also reinstalling roblox in them. This has happened to me and when I did this it was fixed.
Hope it helps :slight_smile:


I’ve experienced this problem before, I would usually use a Browser on any mobile device and log in, and resolve the warning issue. If that doesn’t work, try enabling “Request Desktop Site” and doing the same thing as I said before.

This probably is the easier way, for me at least.


I had this problem about 2-3 months ago. I got warn because of the code decal I uploaded to Roblox. But I didn’t know that. When i tried to login to my account it loads and go backs to login page. I thought i got hacked.

You can easily fix it by going to google on your Ipad or whatever you want. Go to Roblox and log-in your account in Google or Safari etc. After re-activating your account, you can go back to Roblox app and you can login.

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


This has been an issue. I’ve gotten freaked out when vibing on roblox I get logged out and can’t log in. The relief I feel when I see it’s a warning. This should probably be fixed.

I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved? We are having a hard time reproducing this issue.


I found out that the cause of the issue was when your account was moderated with a warning which you did not yet dismiss through the website. Meaning that if you did not yet dismiss it, it would not let you log into mobile, whilst not giving you a reason as to why you can’t log in. So the fix was to go on to my computer, log into Roblox, accept the warning to get access back to my account, and then I would be logged in again.

Hope this helps.


Thanks Alvin_Blox. As soon as there is any info regarding this issue i will pass it on.


An easier way to do was is go on Google Chrome or Safari and do it that way

1 Like