Unable to open Roblox Studio on MacOs

Reproduction Steps

On a MacOs computer

  • Download Studio
  • Open it and have it download to the latest version

(note this issue still occurs even after multiple clean re-installs)


Expected Behavior

Opens Studio normally without crashing

Actual Behavior

A popup shows up saying “The Application “RobloxStudio” can’t be opened”.

Issue Area: Studio
Issue Type: Crashing
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-09-21 00:09:00 (-04:00)


What OS Version is this, and what CPU are you using? I’ve heard there are some problems with M1 proccessors (M2 would also obviously be affected by this).

A complete clean reinstall may help (If you haven’t already, or this is the first time you’ve downloaded studio)?

1 Like

I’m having the same exact problem: Cannot open roblox studio - #16 by Fondatix


1 Like

I am having the same issue. I’ve done about 5 clean reinstalls and have restarted my system numerous times yet the issue still persists. I am on an M1 Max MacBook Pro.


I’m having this exact same problem as well… It’s probably on Roblox’s end and will be fixed soon I hope…

1 Like

Issue should have been resolved.
If you have gotten into this bad state, you will need to reinstall Studio from the website.
If that does not work please reply below.


try turning off the anti-virus, or a simple restart could fix the thing.

1 Like

Just reinstalled Studio from the website again - same issue.

1 Like

@Fondatix Did you use Studio at all today/yesterday and have it working?
When you install from the website are you downloading a .dmg and that is failing to launch studio after it reinstalls?

Yes, yesterday Studio got the new icons and docking update and was functioning fine for the entire day, although with a big performance hit due to the update.

I’m not sure what you mean by the second question. If you are asking whether or not the installer is failing to load then no, Studio installs seemingly fine, it is only after it has installed and I try to launch Studio that the error occurs.

and you are sure you are launching the newly installed studio, and not your old one?

1 Like

Yes, before reinstalling I made sure to delete the Studio from the applications folder.

1 Like

If you run this command in your browser url, what is the result displayed on the webpage.

e.g. {“channelName”:“LIVE”}


If you Install Studio from an incognito window so you are not logged in, do you experience the same issue?

Just tried it, this did not fix the issue.

I am having the same problem, yesterday studio was working perfectly fine, besides the huge update where performance was a little different and visual changes, which were to be expected. So I was stoke to see a new update when I tried opening studio today, but after updating, whenever I click on studio it just bounces one time and it doesn’t even open, there’s no error, no failed message, nothing, not even a white dot underneath the logo. Roblox is working perfectly fine though, just not Roblox Studio.

1 Like

Experience the same issue after updating. Uninstalling and installing Roblox studio does not seem to solve the problem. Tried also installing an older version the result is the same.

1 Like

Same here… I think the latest update messed up things during the installation.

1 Like

Our build team pushed another fix. A Reinstall should now hopefully fix the issue, although you will likely be prompted to update back to the non-modern studio.