Unable to Remove Thumbnails From Any of My Games "Invalid Permissions"


I was redirected to message from this post: Can't remove thumbnails from group game

I am also having this issue with removing thumbnails from any of my group games.

Before I show details, I am the owner of the group - yet I am receiving ‘Invalid Permissions’ when trying to remove thumbnails for a game under the group I own.

For example, if I want to remove this thumbnail:

I click on the small ‘X’ icon in the corner of said thumbnail to remove it, receiving the normal pop-up:

However, once I click ‘Yes’ to confirm that I’d like to delete the thumbnail, I receive this error message:

I am unsure how long this has been an issue, but I noticed it myself today.

For further information:

Username: 1billybob1
Group in question: Tornado Alley Community - Roblox
Specific game in question (though it is important note this occurs for ALL games under this group): Tornado Alley Ultimate - Roblox

Additional information
After further investigation, I’ve tried the following yet still am unable to make any removal of any thumbnails from my game:

  • Tried another browser (tried Microsoft Edge after usually using Google Chrome, no difference.)
  • Tried logging in on an alternative account and making said alternative account a ‘developer’ role, that account is unable to make changes either, met with same error.
  • Disabled ad-blocker (it’s already usually disabled for roblox) - met with same error.
  • Tried removing a thumbnail under a game I directly own (not group game) - met with same error.

From what it seems, it seems like this could be a major issue if developers are unable to remove thumbnails. As of now, it seems I am stuck with the current thumbnails I have. Uploading works just fine, though removing thumbnails is resulting in errors. I hope this information is helpful, but I am willing to look into this more if needed. I would appreciate if this can be looked into, as I plan to swap all my thumbnails out for new ones as I release a major update on Friday.

Edit: Further Info 6/15/2022

  • Using ‘Game Settings’ → Basic Info → removing thumbnails from there works. It is only the website that is throwing an error.

Thank you - please let me know if you need any more information.


We were able to reproduce the issue. We’ve filed a ticket to our internal database, and we’ll follow up when we have an update!

Thanks for flagging!


I thought I’d mention too that while this seems to be occurring to me on all of my places, I’ve noticed that on games with video thumbnails - those video thumbnails also seem to be playing immediately, even if they aren’t selected as the main thumbnail. And if two video thumbnails are present, they both play at the same time, overlapping in sound. I don’t know if this correlates in any way to the main issue of being unable to remove thumbnails - but I’ve noticed this issue around the same time as the thumbnail removal issue.

Thank you so much for submitting this issue for a possible solution. I hope it can be resolved as it’s impossible to make any changes to thumbnails at this time and that can be very detrimental to update success when we want to swap out old thumbnails for new ones to showcase the update. Thanks again!

What could be more important info I’d like to provide - is that this bug likely began sometime after 4:30 PM EST on June 14th. Around that timeframe was the last time I was able to remove a thumbnail because I had an image that I uploaded, reuploaded it once again with a slight modification and removed the previous one - which by looking at the image file’s history, was around 4:30 PM EST June 14th. But after then, I am now unable to remove a single thumbnail from any of my games.

Edit: Using ‘Game Settings’ works in studio to remove thumbnails, but not the website. So if anyone is looking for a work-around at this time, use that.


Just happened to me, hoping this gets resolved.

1 Like

Not only that, but whatever you change your description to. In the edit preview it stays the same as your old.

This seems to be happening to me too, I can’t remove thumbmails, even though I don’t have any video thumbmail

Thank you for the work-around! This works well for the moment.

Still occurring for me, the workaround doesn’t apply to me. I can’t seem to remove my place thumbnail (not experience / start place), but I can still add them. Appears to affect any place.


Additionally, this endpoint appears to give me error 404. Maybe it relates to this change? I’m not sure if it has an alternative for place thumbnails.



This is also happening to me, I am currently unable to remove thumbnails from any of my places. It does not say “Invalid Permission” though.

This message appears in my console when I try to remove a thumbnail, currently there is no workaround.


Oh look here, you have to use the new page! Wowzers!

1 Like