Unable to separate unions?

Hello, I’m trying to separate a union, but it keeps creating the same part repeatedly. I’ve tried restarting and reinstalling Studio, but nothing has changed. I’ve attempted to add a new part to the existing union, but it returns error code -15. Additionally, I’ve tried taking the union to a new game, but it still exhibits the same behavior. If anyone has any advice on how I could fix this, or work around it, I would appreciate it.

Video:

try taking it out of the model

Just tried that, I put the union under workspace and it’s still doing the same thing sadly

maybe it has something to do with this:

Thank you for reporting this issue. Would you please share the place file with us so we can reproduce the issue? Thanks

Sorry for the delayed response, but I’ve found a temporary workaround. As the part moves closer to 0, 0, 0, more parts become un-unioned. I don’t want to share the whole game, but I will share the part. It is attached below.

Video:

Part:
Use this position value: “-276.434, 521.761, 2146.844”
KnobPart.rbxm (39.0 KB)

It might be. I was doing some tests and by moving the union to 0, 0, 0, separating the union, then moving it back to the original position, it failed to union. But deleting the spheres or moving the entire model back to 0, 0, 0 successfully unioned the parts.

Video:

based on what information i have im pretty sure im right but your union position probably has something to do with it as well since the value is so large remember you want everything to be as close to 0,0,0 as possible