Unable to start a new animation

I have a rig containing 6 parts and a model, rigged correctly.
Every time I open up the Animation Plugin it prompts me to select the rig, which I do, and it then informs me it has no current animation loaded. To proceed I need to start a new animation file.
I type in anything and hit create.
Studio freezes, it looks as though its about to creash, and then it reaches its stackoverflow and fails. This is an image of 2 attempts.

Edit2: it appears this bug has resolved itself. I can no longer replicate it.

the (x16368) is in the first error too, just masked by the tooltip.

Edit: Just tried to see if I could bypass this window by adding in an AnimSave model + a previous save from a different animation. Instant freeze on selecting the rig, same error.

1 Like

I have a question of my own related to it…

Is that, I know how to animate rigs, but the thing is, I’m not sure how to create and save my newly created animation… :slightly_frowning_face:

Can somebody explain to me how???

In the animation editor, there are 3 dots above where all your parts are named. If you click on that, it will give you the option to Load, Import or Export.
You want to click on Export. That will upload it to roblox for you.
If you want to work on it again, you can press Import and it will load up that animation for you.

This post isn’t about using the plugin though, this is a bug report. There is a developer support section of the forums dedicated to questions like this, I’d really recommend giving it a look! A lot of the time, questions I want to ask have already been answered there! :slight_smile:

Thanks, kinda understand now, but is it okay for you to show me in photo or even better, video version, that certainly helps👍

Like I mention in the post here, I can’t use the plugin currently. There should be a few vids on it around though!

Oh okay then, thanks for the tip😄

1 Like

Hey edenojack, just wanted to follow up with you on this. So this issue is no longer happening for you? Just to be sure the issue is actually gone, could you provide me with an rbxm of the model you were using so I can investigate? Thanks!

The rig itself isn’t saved, but I’ll recreate it to see if I can get it to replicate again!

Edit: Okay I’ve recreated the rig and replicated the issue as well.
PluginBreakingRig.rbxm (6.8 KB)
In my working copy, I’d renamed the top-level rig’s Primary part to be called “Root”, not HumanoidRootPart. Having two parts called HumanoidRootPart seem to be the cause.

I had an issue recently with the plugin telling me I couldn’t have parts named the same, but there isn’t a warning here.

1 Like

Thanks, if that’s the case we will fix right away!