Unable to upload badge to group game

I tried uploading a badge to one of my group games today and I keep getting the following error no matter what I do:

image

I’ve tried uploading different images, using different badge names, different descriptions, disabling my ad blocker, and nothing seems to work. I noticed there was a similar issue a month ago with uploading badges to group games, but it was supposedly resolved and it also had a different error message.

Minutes before trying to upload this badge to my group game, I uploaded a similar badge to a game on my profile and had no issues whatsoever.

Group Id: 4298891
Game Id: 5470556987

9 Likes

It could potentially be a ratelimiter, try later on. Other than that I’m pretty clueless to what could be going on with this. I’ve never experienced this nor seen it before.

1 Like

Scorned2000:

I had the same issue a week ago. I did everything correct my image format was correct and everything but it didn’t work

1 Like

@Sencives didn’t you also have this problem?

2 Likes

I am also currently running into the same problem. Apparently something similar to this has happened a while back, around 2019. For the past 3 hours, I’ve been trying to figure out why this is happening. I’ve tried uploading it 5 times, taking a two-hour break and try again, like @lexishh is saying, I thought I could be that as well. But I got the exact error and it didn’t seem to fix it. I then tried using several different browsers because I thought it could just be my chrome acting up, nothing worked! I really hope Roblox can figure out why this is happening!

3 Likes

We are experiencing the same issue with badge uploads to a group game. The issue first started for us yesterday.

We were unable to release new features to our game as a result. Hopefully it gets resolved soon.

3 Likes

I am having this same issue. I have tried uploading previously accepted badge images and had the same error. This error does not happen uploading decals or clothing to a group, only badges.

4 Likes

Same problem here, ongoing for over 24 hours at this point.

3 Likes

I’ve been trying to upload badges to my group game for 2 days and I keep getting this problem.

4 Likes

Hey everyone - thanks for the reports, sorry for the late response, but this should be fixed now. Let us know if you have any other issues :pray:

11 Likes