Unable to upload icons/thumbnails to a place

An error occurring every time I’ve tried to upload a new icon / thumbnail starting 30 minutes ago. The Icon was a 512x512 png file and the thumbnail was a 1920x1080 png file as well.

This error only occurs on this specific place from studio and web My Droplets 💥! - Roblox

I have tried the same icons/thumbnails on other places and it works fine.


Error is still occurring but I have new information above.

Been watching this thread, no other response than OP.

I do not know any way to reproduce this unless this is restricted to that place only. Maybe it’s temporarily broken there? We should have someone to look into it.

Longshot solution: Try cleaning the cache, can be a hassle if you do it.

1 Like

I found out that it is a 500 internal server error.

Drawn Conclusion:

This is on the server’s end, it might have been something that went wrong. The solution should be for Roblox Staff to handle, because that’s outside our range of work.

1 Like