Unable to upload to certain models using the new configure asset window

This should be resolved as of the latest Studio update. The focus of this fix was to make sure all assets load. We are looking into improving this further in the future, for example improving performance and user experience when loading large amount of assets with this window.

Thank you for your patience!


im still having problems with it, i can now scroll further down, but the scrollbar reaches the bottom after 24 rows of 3 models, not allowing me to update any other model after that


Getting this too in some inventories, but switching to a different inventory and back usually fixes it for me.


This still isn’t functioning properly.

I’m able to do this to get more of my inventory to load, but not all of them.

This is not loading every single one of my models. If I go into my inventory from the website and view my models, I can see that in comparison to the toolbox, some of my models are there and are correctly ordered by creation date, whereas others are just plain out missing, where they should be, but are not.

Again, I am left unable to update one of my models (which is a module) that requires an update for games that use it.


Actually I just tried it today and randomly I am unable to continue to view the rest of my models beyond the 8th row the scroll bar stops here.

I cant scroll past the 8th row even when I restart studio, its not random anymore it’s happening consistently in the same fashion as the 4th row issue.

The issue is only occurring with groups and my inventory that have a lot of assets, so it may be due to the amount of assets?

The following information could help whatever team or individual is working to fix this:
I discovered that I could only scroll as far in the update asset window as I scrolled for that creator in toolbox.

  • I scrolled down in the group FeudalJapan’s Models (Using Toolbox).
  • I was then able to view those assets after opening the Update Asset Window.

Hope this information helps for an easy fix!


DataStore2 is used by countless developers, but for the past several months it hasn’t showed up in player’s toolboxes. For a fix, I’ve asked developers to do this while I investigate:

Now, this has become a more serious issue–I cannot publish over it anymore.

When I choose assets, I can only see this:

This is not the main DataStore2 module–the actual one does not show up.

I’ve not received any messages about this, and DataStore2 has been mostly rewritten and will in the very distant future allow methods that do not take up nearly as much data. If Roblox wants to deincentivize its use because of the current method, blocking me from fixing it is not a productive move.

Furthermore, considering the amount of developers that use DataStore2, blocking me from updating it means any critical issues I find (including ones that cause stress on Roblox servers) are less likely to be fixed across the games that use it.


Hi Kampfkarren, I’m trying to track this issue down. I was wondering if you still have the original/main DataStore2 in your inventory or if you have deleted it?

If it’s the latter, would you re-add it to your inventory and see if you can overwrite it then? Thanks!



I do seem to have it in my inventory.


I’m having the same issue as LadyAka. It appears models past however many lines the last group I clicked on had still aren’t showing for me on this one group:

Compared to my develop page which shows them all:


Sorry for the delay on getting back to you… Thanks for letting us know. It seems like we are closer to fix and understanding the issue. I will be sharing more info as it becomes available, but this is a top priority at the moment and want to put out a fix soon.


This issue caused problems today with my admin system across all games which handles a large amount of in game elements as well, I am unable to update the module I need to as it wont let you scroll down far enough. Hope it can be looked at soon.


My game relies on a module, and I can’t update it due to the fact that I can’t scroll down far enough to publish new versions of it, which essentially halts production on my game. I’ve been having this issue for a while now, so I hope it could be fixed sometime soon.


As of today, I cannot chose “overwrite asset” I need this functionality ASAP.


This is still an ongoing issue that has yet to be fixed.


I’m continuing to have this problem and with the introduction of signatures/BuiltInPlugins verification, I can’t even solve the problem myself by making a fork of the Toolbox plugin because it doesn’t get loaded as a result of a security violation.

This is an insanely annoying problem as assets in my game are loaded from a model and I can’t update that model thanks to this new toolbox. This has been an issue for a very long time and I’m shocked it hasn’t been fixed.


I’m getting this same problem as well. After messing with it for a little while, I figured out something you can do to work around it. Find the model you need to update, delete it from your inventory, and then re-take it. Now it should appear on the top of the list. This won’t work if your model isn’t free, so you may have to temporarily uncopylock it, then delete it, grab a new copy, and then copylock.


it’s been over a month since any roblox staff has said anything and the issue is still there, how hard can it be to just increase the number of models you can view in the toolbox, its been like 4 months since you introduced this new toolbox and its as useless as ever because of a really basic issue, just give us the ability to update all of your existing models or go back to the old one. like they say if it aint broken then don’t fix it


While my issues are solved for group games, I’m now experiencing this issue with my own models.

When attempting to upload models to my own inventory only 3 assets load:

Once I change it to a group of which I can edit assets, I’m no longer able to re-load the page of my own assets either. I’ve left it on this screen for a few minutes in hope that it will load, but it never does. It simply shows the group assets that had loaded when I had last changed it to my group.

I’d like to note that it worked on 10/29/19, but it doesn’t work anymore.


Can confirm that this is still an on-going problem:

Dunno if showing that video would even be any help, but I might as well.

3 months and waiting

Hopefully this can be fixed sometime this year as this is starting to become [color=red]frustrating[/color]. Not even uninstalling/reinstalling Studio helps.