Unable to use Humanoid:MoveTo() on custom rig

Ok so currently i’m scripting a boss rig for a game and i’m using a humanoid moveto function (ik i can use body movers but since i’m using humanoids for the bosses id prefer to just use them).

https://gyazo.com/4de368127688add383ce49fe9f19ffd5 gif of the rig trying to move to world space point 0,0,0. not even facing in correct direction.

I tried playing around to see if the rig was too heavy / not heavy enough by changing density of the parts, tried editing walkspeed, HipHeight and tried without animation however no solution worked.

Anybody know how to fix / how to work around this?

This may be the wrong category, however since i do not know the origin of the issue this was my best guess.


You should provide the code that you’re using. Either way, cool boss.

I dont see why the code is relevant since its just a standard MoveTo() function, however here it is:

local IdleAnim = Instance.new("Animation")
IdleAnim.AnimationId = "rbxassetid://4115907605"

local MovementAnim = Instance.new("Animation")
MovementAnim.AnimationId = "rbxassetid://4115973978"

local AttackAnim = Instance.new("Animation")
AttackAnim.AnimationId = "rbxassetid://4115987035"



Are you missing an element in the boss? Like something related to the humanoid.

19 i do not believe so, here is everything inside the model

1 Like

It’s still good to have it there. What position is the boss at? Maybe it’s alreay at 0,0,0?

It 100% is not at 0,0,0. that i am sure of

Correct me if I’m wrong, but terrain takes material into account. Consider that your boss seems to be made out of metal? Could be a density factor you’re not aware of.

Boss is made out of smooth plastic

That’s super weird. Yeah, I’m stumped. Perhaps do some testing without the animation playing.

Have already done this, as stated in scenario

1 Like

Still stumped on this, i ran the same code on a normal rig and it worked so its def not the code, if anybody would like to play around with the rig to try and get it to work it would be appreciated.

1 Like

What you need to do is to make the HumanoidRootPart not anchored that will let the character move
I tried it on my own and it worked.(Sorry for not being able to answer I just became a member!)


@anon92559147, just to add some informations of what @blockmasterDM777 said, you should also think to change the HipHeight Property of your Humanoid, I had the same problem and this is how I solved it: