Uncopylocked places (i.e. places with 'Allow Copying' set to true) infinitely load for other users when clicking Edit

When setting a place to ‘Allow Copying’, others users can no longer open up the place. Instead, it loads infinitely, with the incremental message ‘Loading game (attempt #i)’

image

This has been confirmed by multiple other people and occurs 100% of the time when clicking ‘Edit’ on accounts which do not own the original place.

Many developers prefer to share place files this way for security/trust reasons instead of using off-site file sharing.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2022-03-21 00:03:00 (+00:00)

13 Likes

Are you sure? It seems that I cannot reproduce this problem on my PC.

What happens when you click Edit on the following:
https://www.roblox.com/games/9175719894/Untitled-Game

3 Likes

I get similar results as mentioned in the post. Could it be because the place is private? What happens if you set its status to public? Also, downloading the place and editing it offline works fine for me.

It appears to be the same for Public experiences:

How are you downloading these places?

3 Likes

Probably using extensions, BTRoblox/Roblox+ allows downloading place files, or using the endpoint that downloads the place file

2 Likes

I have already experienced this issue multiple times and can prove that the issue exists.
Downloading via BTRoblox works fine for me.

never imagined to talk to ForeverHD :slight_smile:

2 Likes

I do get these errors on team create places when opening directly from RBLX Studio but i just go in create and click edit. but as i am not a regular and may never be i cant report it

1 Like

Yeah, this happend to me too.

A game recently got uncopylocked, which I wanted to study and view the scripts.

But INSTEAD, it gave me the same error it’s giving you, i’m not sure to the fix to this, but i think the uncopylocked games options are being deleted?

1 Like

Thanks for the report. We are investigating the issue and we’ll come back to you with any updates we have!

9 Likes

Any Updates from your side?

It’s July, not March


This issue also only occurs when TeamCreate is enabled.
A workaround is, to disable TeamCreate, which isn’t very good, cause many developers need TeamCreate.

Yeah, it’s totally not working :frowning:

1 Like

It’s fixed now and it’s working! ><

2 Likes

I can still reproduce it on my Mac. Or do you mean the place he showed works now?

1 Like

This happens for specific experiences but not all I am very confused about why.

1 Like

Recently today I tried to open an experience but this appeared to me
image

1 Like

Any updates on this being fixed? This problem is still occurring to me.

8 Likes