Union Collision troubles

Hello, fellow developers!!

  • What are you attempting to achieve? I am just making a game, but the unions inside of the game are having weird collisions.
  • What is the issue? Some of the unions in my game, have some very strange and weird collisions.
  • What solutions have you tried so far? I have tried un-union-ing it, I have tried setting the CollisionFidelity to all the available options, and it still has the weird collisions.

https://youtu.be/A4fqIGegjQk (To see the collision problems) Also don’t mind my characters back issues, we are just having some fun with stuff :slight_smile:

Thanks for reading, and if you can or can’t help, just thank you anyway!

Dont use unions

Also I think this bug is only for you because I hade no issues like this before

1 Like

I’ve had that problem before all you need to do is make it so the part is far away from the door.

And sometimes when I do unions I turn off cantouch and cancollide and that should fix it.

Union collisions are pretty messed up and if you’re doing a doorway as simple as that then I strongly advise you not to use unions and just use parts to build your structures

I’m confused on what you mean?

Yeah, I will probably end up building the door ways from scratch. But what about the cylinder? I’m not sure what do for that, or should I try and send this bug to Roblox, and see if they can do anything?

I mean like you can disable can collide so then you can walk through the door smoothly.

Once you did that you should be okay.

robloxapp-20210416-1312472.wmv (927.3 KB)

I sent you a video of me walking through the door smoothly with those cancollide cantouch off.

Do you mean CanCollide & CanTouch get turned off under the NegativePart? if so I’ll give it a try and see

Kk, give that a try and it should work.

And yea, that’s what I meant to say turn off cancollide and cantouch that’s what I was trying to tell you.

This bug has been for a while now, but it is possible to manually build a perfectly symmetrical cylinder.

When I use unions (in the playable area) I set the union’s CollisionFidelty to PerciseConvexDecomposition as it works the best for me. I rarely have weird collisions with it.

But if that does not work you can always try to use invisible “Collision parts” to make your own collisions. (You need to disable the union’s CanCollide property of course.)