Union Invisible after Creation

Okay, so before making any assumptions or trying to help me, here is what has happened.
So a few weeks ago, i made this union. It was visible at first, but after a couple of minutes I tested the game and saw that the union was invisible. I thought I had deleted it, but I was wrong. The hitbox itself was still collidable. Here is a video showing the hitbox:

Upon negation or trying to union it with other objects, this shows:

Separation yields the removal of the union, and no parts of it is left behind.

Keep in mind, This union was created weeks prior, and it has still not become visible.
The transparency is set to 0, and there are no problems with it at all other than the problem this post is about. Putting a decal or texture on it does not work as well.

Trying to recreated the union has also yielded several issues, the main being I forgot how it looked and I did not have the precise records of the properties of the makeup of the union.

Please help, I am struggling to find a fix for this.


Many others have had this same problem before, including me. Here’s a post that may help:

Nothing in that thread fixed my problem. I tried deleting the temp folder, reloading my assets, nothing worked.

I’ve also experienced this and don’t have a good fix for it. I had to redo what I did, and so far, they haven’t disappeared.

I’ve never before had this issue or anything like it, I recommend just separating the union and grouping it instead.

Is it invisible both in-game and inside Roblox Studio?

Invisible in both. Like I said, the hitbox is still collidable in both studio and game.

Hey, iSyriux

Repeated Answer

This question has been asked countless times, please use the search bar on the top right next time to look for references then ask your question.

Post With Answer

Hope this helped!

The post you linked has no relevance to OP’s question.

This is an extremely prevalent problem with CSG Unions currently, possibly with a recent Roblox update that broke how CSG is loaded. I hate to tell you this, but there is no way to recover your Union, since it’s a corrupted file. You’ll have to rebuild it.

I think this is something that Roblox definitely needs to look into.

That’s deeply problematic, and very unfortunate.

It looks like you would be better off learning how to use a 3D modelling software in the future for complicated models rather than risk the unreliable mess which is CSG.

You should definitely add to this thread; it is not acceptable for work to vanish just like that.

The CSG Union becomes corrupted when you undo or redo at times. I am not sure how prevalent you would need to do this for this to occur but there is no current way of fixing this. Even opening versions saved from before doesn’t fix this. From what I believe, the only way to avoid this completely is by disabling CSGv2.

I’ve experienced this issue multiple times while in the studio. While there is no fix at the moment, the best thing you can do is once you have placed the union where you want it to be, un-union it and group it, then press can-collide on individual objects which may need it.

Another issue may be overlap. If you union parts while some are ‘collidable’ and others are not, then you may experiences errors while attempting to union a part. I hope this helps, as its what I do when this happens to be. Good luck. :slight_smile:

1 Like

I just make it a point not to use unions they are way too unstable

Yeah, this happens with me also, Can someone help, please?