My Unions Have Disappeared

I’ve made a bug report on this exact issue : CSGV2 still gets corrupt unions


Did you have a stable internet connection while you were working on them? Were you possibly working in offline mode?

Perfect connection, and I tried restarting my laptop multiple times + using Ethernet.


I got my friend to try the place file and the unions showed up. Must be an issue with my pc/studio. I tried disabling anti virus and doing a full reinstall, nothing worked. I’ll do some more research but if anyone has advice it’d be appreciated.

it’s an issue with your internet, something to do with the connection that the unions don’t load properly.
i had the issue before and there isn’t really any one way to fix it, just mess around with your connection settings and try to see if it stops.

1 Like

Every other union does load though, It’s just the ones in this specific model :thinking:

try separating the horses.
if you can’t separate them then you probably did a certain union that usually is not supported by roblox or something.
i’d just recommend redoing the unions, they look pretty simple.

It’s not redoing them that’s the issue, I spent hours rigging and animating them.

Also small update, this error is now showing:


Hi! I hope my response isn’t too late.

If your unions only turn invisible, separate the union and re-union it again, it’s the only way I know of ‘fixing’ the problem. However if the entire union brick disappears somehow, then I’m not sure. I really hope this helps though ^^



Hey, can you try deleting your cache?

The cache should be located in C:\Users\<your username>\AppData\Local\Temp\Roblox. Deleting this folder shouldn’t cause any issues, but just to be on the safe side, make a backup of this folder elsewhere. Also, only do this with all instances of Roblox/Studio closed.


Are the Unions still in the Explorer? Had this issue a few years ago and remember fixing it by uploading the entire group as a model and then placing it back into the workspace via “My Models”.

1 Like

Tried this, but separating it just deletes it :frowning:

1 Like

Ah jeez! Thanks you, that finally fixed it. Happy to say the horsey bois are back in action.

Thanks to everyone who gave an answer to this issue :slight_smile:


I just ran into this issue and cannot find the file to delete that you said to. e.e

1 Like

Try turning this setting on Reload Assets in the settings and then restart all instances of Roblox Studio:



I’ve tried dong ReloadAssets, Deleting my Cache, Publishing the model and re-inserting it, and everything else I’ve seen on the web about this. For some reason none of it worked and it’s a big problem because I have a full on character made only out of unions and last night I spent a good hour or so rigging it up, and then when I got on this morning, the whole model is completely invisible and separating only deletes the part. Is there any other solution to this that you could give me?


I have a few questions from my experience that might help solve your problem.

  1. Does it show if you send it to a friend and they open it in studio on their PC?
  2. Does it show in game? (viewing it in the Roblox client, not in Roblox studio)

The character model does not load in-game and my friend cannot see the model. I hope there’s a way to fix it…


Issue now occurring for me, tried all solutions above except clearing cache as I don’t know how to clear it on a mac. Any help?

I saved my union + game, then came back after a while and boom its gone. Separating does nothing, unionising does nothing either. Tried switching to V2, however it just deletes my union. It’s throwing no errors at me either.

i had the same problem, wont work.