Union not here when loading in roblox studio

I want to post it in the “bug” section but can’t since the devforum is badly made :confused:
My problem is that in studio I made a union :

but it’s not here anymore. The union part is here but invisible, if I try to separate it just disapear without separating ( can still ctrl Z to get the union back but still invisible ) . If I try to negate I get that image .
I tried to play the game on roblox (and playtest in the studio ) and they are also invisible. I could make them again but if they become invisible the next time I load it’s useless. I tried to load from roblox and from my savefile on my computer and both have this problem.

there might be a virus inside your game check all the scrips.

I make all the scripts myself so nope there is no virus

This is perfectly normal, unions go corrupt all the time. If it didn’t go corrupt, you’ll be lucky.


Nice haha, so nothing I can do to prevent that ? Guess I’m just going to make a cylinder then… The union is originally a circle that goes around the table leg and I didn’t want it to be inside the table leg

This is a known bug with unions, really just don’t use them at all :confused:.
You can find other topics on the DevForum about it.

@Nightmare4into96 is correct, they just corrupt…

1 Like

You could go for meshes, meshes are much better than unions. Plus, they don’t go corrupt.

Yea but that mean going through another software and I’ll need to make the entire table again or get the precise mesurement of the circle that I want. why roblox why are you so badly made…

If you really want to use unions you could export the union to a .obj and import it to ROBLOX. (at least I think it might work)

This is a common problem and a known issue that’s been happening for a while now. A simple solution would be recreating the union that’s been corrupted regarding that’s a only way. In your case I wouldn’t use a union for something that simple, making a circle around a cylinder could be produced with using a plugin such as ’ Archimedes Two’.

Try to minimize on using unions for simple objects; you’ll have to remake it, this is a common question that’s been discussed in previously threads. Here is a tutorial that goes in depth about recovering lost - corrupted unions.