Unioning Problem

This is not default text. I have a problem regarding roblox studio. It doesn’t let me Union some parts with each other. And since I don’t have the privileges to post on Bug reports for some reason, this is the second best place to post, I guess.

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
  • I would like to make a fancy-looking door with indentations in it for my horror game:
  1. What is the issue? Include screenshots / videos if possible!
  • CSG literally can’t union simple parts together. It doesn’t even have meshes in it, simply parts, wedges and corner wedges. When I try to union them, it promps this window:

  • (The output says the same text above)

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
  • The window literally wants me to file a bug report, which I cannot access because I’m not on this site 24/7 (No offense)

This problem popped up yesterday when I tried [making the door] for the first time. After trying a lot of times, I gave up. Today I gave it another shot, and made good progress as you can (maybe) see in the picture, the four decorations could be done with unioning them step-by-step, but unioning all four with the base of the door just didn’t work. The doors are just for decoration at the moment, but I plan gameplay mechanics for them, which I would like to use the decorated ones for.

Any help appreciated!

1 Like

Sorry that you encountered this CSG error. Would you please share the file that you received the -11 error so that I can reproduce it? Thanks!

1 Like

This issue mostly occurs with the CSG Version 3 Beta. Disable it.

Sure thing! I put a link for the door I uploaded to the toolbox:

Hope you can work with it.

Try Unioning the door, although Negating and Separating is also not working.

Thank you for helping. After disabling, CSG finally unioned the door, so it’s a temporary solution to this problem. Though I’m sure the new version still isn’t supposed to error at this. Hopefully it gets resolved!