Unions broke or has stopped loading

Hey all. Lately iv’e been working on a Tommy Gun model that is made up of three different unions. I saved my work. 5 minutes later, I open studio. I lose an hour worth of work. The union has stopped loading. And it doesn’t seem to ever be loading. even when i try to reopen studio. The union also doesn’t load in-game either. I can see the shadow of the union from above, But the union is still not visible. I can’t even separate the union. Is there any way to recover?


There are a few solutions.

  • Go back to an old save where it appeared
  • Try to put the unions into another game/place
  • Export and import your union as a meshYou may lose the colors
  • Disable CSGv2Settings > Physics > Scroll all the way to the bottom

However, if all else fails, I’m afraid you will have to rebuild everything.
Good luck!

Edit: If I am not wrong, this belongs in #development-support:building-support


Hi, this post has been made many of times before. I suggest using the search bar before posting!

1 Like

None of these worked, but thanks for your help anyway.

1 Like

I am deeply sorry to inform you that this currently a major big within Roblox. Your union has corrupted. You will have to remake it. However, you might want to try to debug it and view other topics related to this.

1 Like

I have looked far and wide, this is the best result I have discovered: