Unions not showing when saving or transferring to another place?

#13

image

#14

You told me it wasn’t 0. Now you say it is 0.

I was responding based on the answer you gave.

#15

I said it was 0.

#16

Now that you’ve edited the original answer to change “isn’t” to “is”. I was acting based off your typo.

What happens if you try to separate the invisible union?

#17

It just… well… disappeared from Workspace.

#18

Then I’d assume that it is lost due to an error in the union. Do you have a copy of all the parts before you unioned them?

If not you may have to do it again, and save a backup of the separated parts in case it happens again. If you didn’t receive any errors when forming or separating the union then it may be tricky to find the cause.

#19

This is the first time it has happened to me, and I Don’t understand why. All I did was separate it, repaint some stuff, then union it back before trying to transfer it to my other place. Then I saved the file and closed Studio as I had to go somewhere, came back and it started happening.

No, no copy. Because as soon as I saved it they all disappeared and it was too late when I noticed.

#20

Try turning on ReloadAssets under Settings>Rendering and restart Studio then reload your place.

#21

Not an answer to your issue, but I experienced the same error yesterday. Separating just makes the parts disappear like they never were there. It also turns a -25 error if I remember correctly.

#22

Have you saved it to Roblox as a model?
I’ve had this glitch before with unions. However, it’s not the end of the world, as you could try and save it more than once or save individual parts of your train. By that, I mean you could save all of the unions together as a model and just gently pop them into the place where they were in the original model. Unless if the glitch doesn’t happen again, I guess!

#23

I haven’t had too many problems when it came to this, my best guess is to publish it as a model and try from there!

#24

I’m not sure what’s going on, but this issue has been happening to a LOT of people recently. A bunch of my builder friends have had this happen to them in the past couple of weeks or so, and I have had it happen too. I’m not sure if a recent studio update is causing this, or what, but none of the current solutions (the re-render setting and clearing cache) seem to fix these issues. You might want to submit a bug report if no one can find a solution for you.

#25

Been having this problem as well, I found a fix that atleast stops it from happening 80% of the times I union stuff, as far as I know this is because the file of the union corrupts and it happens a lot while using CSGv2 so my suggestion would be disabling that and see if it keeps happening, also I’d suggest keeping copies of your models from before unioning it so you have a backup.

TL;DR, try disabling CSGv2 and keep backups of your stuff before you union it.

billede

1 Like
#26

Unions can become corrupted, it’s actually pretty annoying, and has happened to me a number of times.

Unions Failing to Load I’ve made a post similar to this in the past, you can read it if you’d like.

Unions Aren't Loading Also, there is this post about it too.

It’s a ROBLOX glitch, and as of right now, I do not believe there is any fix to it, other than reloading old place files. If you cannot load it into another place, I believe it’s corrupted. :frowning:

1 Like
Unions sometimes disappear when saving
#27

I have been getting this issue too, its really annoying and roblox needs to fix this. I really dont want to use V1 because in the future it may cause issues if roblox decides to stop supporting it but I have to.

This issue is relentless, I think its better to deal with that other annoying error in V1 then this stupid disappearing parts issue.

1 Like
#28

Your potential problem and your solutions
You do not have decals. Decals work best for sides. If you cannot do decals, I suggest you use ‘Parts,’ or ‘MeshParts’(MeshParts require UV wrapping/ texture baking skills) to be the side as smoothly as you can. Unfortunately, your sides do not have enough polygons, a glitch has deleted the Unions (check Explorer, you can try copying the sides, and pasting it on once you have to load the other parts), or check the transparency, or lighting. GL, and I hope you fix this problem. Double check everything on properties before doing anything as well.

#29

Have y’all tried saving the mesh as an obj file and opening it with blender? If blender can’t open the file, it’s most likely that the mesh is indeed corrupted, however if blender can open the file, reupload the obj to studio via the assets tab and I guess this would allow the union mesh to be used repeatedly in different games/universes.

This is all theoretical…

#30

I’ve also had this issue with multiple unions in Studio, really hoping for a fix to restore them.

#31

Hey! Could you try separating the union and unioning it again? It may help.

#32

I forgot about this. Yeah I scrapped my train I just decided to get new ones built so…