Universe teleportation is broken for Android Devices

ROBLOX for Android does not currently work with the Samsung S6 or S6 Edge. There’s some hardware issue that messes up our rendering. No ETA on a fix.

@Ripull: Thanks for the report & test places. We’ll take a look at this, but it’s very unlikely a fix will make it out before EOY.

We’re 6 months into 2016 and this is still occurring. Can this please be looked into?

Thanks.

You mean specifically the teleporting issue, not the S6 issue, correct? As far as I know S6 issue is resolved assuming you have the latest Android update on the phone and the latest ROBLOX app.

Yes, the issue unrelated to the S6.

I believe @darthskrill is working on a fix for that.

1 Like

yeah currently testing this

1 Like

Thanks guys

Wait, is the unrelated issue the issue where teleportation on Android just never loads the place? My dev team is having this issue with our new game Fun Run. It’s ruining our likes, but we really want to have the game on mobile, since it works for iOS.

Yes. After teleporting, it either takes ages to load and eventually shuts down before loading, or the client crashes after attempting to load the game for a while.

Is there an ETA on this bug fix? My dev team and I don’t wan’t to have to disable our game for mobile, but if the fix is coming soon then we might.

We just released a version yesterday for android that should work, let me know if it doesn’t

Just updated and tried the fix. The game never managed to load and ended up saying that the game shut down.

Before the update, while attempting to load the game, the games name and creator would appear in the bottom left, now it doesn’t even do that. I’m using an Acer Iconia One 8.

I still haven’t gotten the update. The last time I updated the app was on June 8th, which was before you say you submitted the update.

Sorry about that, it’s my bad. We skipped last week’s Android release.

There will be a new version released tomorrow that will have the fix darthskrill is talking about.

1 Like

This is still not working. When I try to play my game it never loads and I just loose connection and it shuts down.

Any chance this issue will be resolved? Currently I can’t teleport in any game using a Samsung Galaxy S7, which is a bummer since my racing game won’t be playable on mobile with this bug.

For a game that has a custom Image when teleporting, the image shows and the topbar is visible, with the buttons on the topbar seemly working, but the game doesn’t load.


Place: https://www.roblox.com/games/146204374/HHCL-Lobby#!/game-instances

For a game without a custom image it gets to the default loading screen with the name of the game visible, but just loads indefinitely.


Place: https://www.roblox.com/games/262530404/Version-B-Pulse

Edit: Bump cause it’s not Sunday.

Unfortunately, every time we try to enable the flag that will fix this, something else ends up breaking.

We think we’ve finally fixed all the bugs though, and I believe we’ll have a version out next week that we can try enabling the fix on again.

1 Like

Still happening to me on Heroes!, which I’d a mobile focused game. :frowning:

This is alienating a portion of my fanbase. It is really bad.

1 Like

:frowning: