"Unknown Error" When Uploading Roblox Ad

For some reason whenever I go to upload an ad for my game, it’s unable to go through.
It keeps coming up with “Unkown Error,” However I’ve made sure that the ad is the correct resolution and the right image format. I tried using different browsers and even tried on my phone. It’s been doing this since yesterday afternoon.
I’m not sure what’s causing this, please help!

I use Windows 10 PC, and my adblocker is disabled. (I’ve made sure!)


Thanks for the report! We are aware that some users are experiencing this problem on the new page and we are working on a fix for it. I unfortunately don’t have a workaround for this right now because we haven’t been able to reproduce it consistently - it seems to be related to connectivity and timeouts so if you’re on wifi and if you’re able, try off of wifi?


I enabled a VPN while uploading the ad, and it happened to work this time!
Thank you for replying! ^^


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.