Unknown gui shows up, not made by me.Cannot locate source

When I play the game in studio or with my Profile on roblox the gui does not show up.But when I play on account that does not own the game this gui shows up and i have no idea where it is and how to get rid of it.I dont even remember adding something with a script from a toolbox recently so no idea how it got there.The issue is when i try to search for scripts i cannot find where it originates.All of scripts i checked so far were added by me.

Check out for what plugins you have it may be caused from plugin try searching playerstats in find in all scripts tab

In Studio, in explorer, you can use the search bar for ScreenGui and Frame to see what pops up. It could be in a model, tool, or something.

Tried that, still nothing suspicious

The plugins I use are classic plugins everyone uses (tool grip editor,Archmedes,Moon Animator,AutoScale) Tried to search playerstats but nothing showed up

Could it be getting pulled in by a script? It looks like a store GUI. Did you reuse elements from a different game? Scripts, packages, etc?

It is, the question is what script, and i did not add anything new,even tried to revert to older versions from yesterday where i only changed my gui poistions and images.

Did you reuse any game elements like scripts or packages? It could be something from a different game. Do you recognize the GUI? It looks like a store front.

Are any modules being required? They are a prime location to start looking. You can also use the Find All feature in roblox studio to look through all scripts quickly. If you find the GUI in the explorer you may locate it by searching for either it’s name or it’s parent in scripts.

I never used this style of GUI or the types of gamepasses,so no clue how that got in. The thing is it was not there yesterday,and then its just there.

1 Like


this is a backdoor check if your plugins are original

check for obfuscate scripts require or getfenv


your output says a third party sale made by a different user.

original plugins:


tool grip:

moon animator:

auto scale:

Hope i helped you

if you dont find the script you can use Server defender by @Madpoint83

– paulocezarnbr


Are you working in a team environment or is it just you? Ifkpop also had some good ideas to look at. I would suggest the same. If you do not find anything, and you didn’t create it, then there’s two possibilities left.

  1. It’s a Roblox error in which they somehow crossed someone else’s game with yours.

  2. Someone hacked into your game and injected new assets on the live server.

For either one, you would have to contact Roblox and report it. However, there’s a few things you can do for case 2. Since it’s not in studio, you can shutdown the server and republish your game. The development environment and the live server are separate virtual environments. So when you publish something, the virtual machine on the live server gets overwritten by the development environment.

So, try to republish your game and see if it goes away. If it does, then you have a hole in your security. If not, then it’s somewhere, somehow in studio. One thing you can do in studio settings is turn on Show Hidden Objects. It’s located in Studio Settings → Studio → Explorer. It’s toward the bottom of the list. Beyond that, I don’t know.

1 Like

@Maelstorm_1973 this is a backdoor from free models my game has this when i has new to roblox just remove backdoor script searching for require get fenv or obfuscated scripts + see if your plugins are original.

In studio, check the camera, terrain, and other stuff. If you find something like --this script was generated by studio that means that it’s malicious. I do want to study these, so if you could, I wouldn’t mind if you sent them. After that, delete the script.

1 Like

One time I encountered a virus from a free model. The model had something like 120 scripts. I removed all the scripts and used the model. I also reported it too. So all the scripts that I have I have either written myself or I personally vetted.

1 Like

I would like to take a look at it too.

1 Like

Tried running the server deffender.Got 1 plugin and 1 script in weld that i removed, but the problem persists

The person that created it was really clever by hiding it from the creator of the place. No console output, gui does not show in studio or roblox for me.But when i log in from my alt it shows up.Only lead are the dev console logs i posted.

1 Like

You must show hidden services in the studio settings.


you published the update? if you dont find the script i can help