Uploading badges through studio won't work


#1

I am not sure when this change happened, but now you have to upload badges using an option within Roblox studio.

However, whenever I try to upload an image and purchase the badge it tells me that the file I am uploading is not an image.

I have tried it with a JPEG file and a PNG file.

image


Unable to create badges
#2

Can confirm that it is refusing to upload any of my badges. It is infuriating that the website upload feature was removed before it was confirmed that the alternative works. It feels like there’s a quota to remove web features and someone gets fired if it isn’t met in time.


#3

I’m currently trying to make a badge hunt and considering that this has been the case for four days now it’s rather frustrating


#4

Thanks for the report!

The issue has been reported to our engineering team. We will be updating this topic when we have more information.


#5

I have had this issue since February 28th, I was able to create a badge on February 27th in studio just fine.


#6

First post I’ve seen covering this issue. I have followed the instructions (https://developer.roblox.com/articles/Badges-Special-Game-Awards) thoroughly day after day and the badge still wouldn’t upload. I’m unsure if badges require some sort of exact .png formatting or what it is.


#7

I believe that it won’t accept anything, I’ve tried a 24-bit png and an 8-bit png to no avail


#8

Damn right, If a feature is gonna be removed in order for a new feature to take its place, then at least it should be checked if said new feature truly does work.


#9

Having this same issue. Pretty frustrating that the site version worked just fine and now we are stuck with broken studio as only way to upload badges.


^ also robux place-holder isn’t correct R$ amount


#10

Oddly enough, after several hours of pending the thumbnail appears in the configuration menu, but it refuses to recognize it as an image. I’ve tried PNG and JPG formats, with both previews eventually loading but unable to complete the transaction. Does Studio not understand its own definition of “image”…?


#11

I am having the exact same problem with uploading badges


#12

Can confirm still broken as of March 12th.


#13

Apparently it was fixed for personal uploading but is still broken for group uploading.

Either way this should have been reverted as soon as the issue was noticed.


#14

Still broken for group uploading!


#15

Hi night. Is there any more information on this?


#16

Engineering team is still actively looking into this issue and releasing a patch soon. Unfortunately, we don’t have an ETA at this time but will keep you up to date about the status.


#17

Great news!

Engineering team has released a patch which fixes this issue. Please let us know if you run into any further issues.