Uploading thumbnails in Translation Management is not working correctly

Reproduction Steps
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0
Platform Type: PC
Device Type: Computer

Steps to reproduce:

  1. Go to Game Info → Thumbnails when translating a game
  2. Upload 1 or more thumbnails
  3. Press Save
  4. Go to another tab
  5. Return to “Thumbnails”

Expected Behavior

  1. Not be presented with “You have unsaved changes” when trying to navigate to another view
  2. See that I have thumbnails in the moderation queue or that they are already uploaded

Actual Behavior

  1. I get presented with you have unsaved changes
  2. When I return to the “Thumbnails” view I have no thumbnails

gif to illustrate the problem

No - uploading translated thumbnails does not work. Two of the thumbnails should not require moderation since they are used in the default.

Issue Area: Roblox Website
Page URL: Roblox
Impact: High
Frequency: Constantly
Date First Experienced: 2021-06-13 00:06:00 (+02:00)
Date Last Experienced: 2021-06-13 00:06:00 (+02:00)


I just wanted to add, almost 24 hours later I still do not see any thumbnails.

So the feature does not work at all it seems.

Hey @SamSwifthoof thanks for reporting. What size are the thumbnails you are trying to upload?


You solved the issue - one of the thumbnails was 3024x1701 (4.79MB) which exceeds the file size limit that is written in the upload form (did not notice the file size before). When I tried to upload a single thumbnail I managed to pick that one too.

So I guess some kind of error feedback could be nice, but the feature is working. :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.