Using Future is bright in builds issue

thefutureisbright

#1

Hello Developers,

Recently I have been using the future is bright a lot, though it has entered Phase one of its release it has many bugs. The most common I encounter is the light is patchy, having a surface light which is fairly bright looks super patchy in studio. It would be great if this was fixed. I am sure there is possible ways to overcome this though, like changing things in lighting, if anyone has any solutions for this, replies are greatly appreciated.


Update:
I have sent a post ready for approval to be posted into bugs, which then roblox themself can just see if maybe they could space out the brightness or lower the max slightly. Thanks to all who posted. Main solution now can be found below.


#2

Do you have photos of the problem you could share as examples so we could get a better idea of what the issue is?


#3

@Unresolved The photo has been edited into the post.


#4

It’s probably a good idea to post this as a bug on the original thread if you don’t think this is intended behaviour:


#5

It appears it only happens with ultra-bright colors.

The darker the color the better the blending job tends to be. Even with the brightest colors the problem can be fixed by turning down the brightness from its maxed setting slightly.

However, I do agree that regardless of brightness the “patchy-ness” shouldn’t be taking place.


#6

Have you made sure to change the Lighting.Technology property to Future and increased your graphics level (only needed in Play Solo)? The provided picture looks like a regular voxel light.


#7

Can you explain more please?


#8

Assuming, you mean the Lighting.Technology property, V16 has the following:

  • Legacy (also on production): Old voxel lighting engine
  • Voxel (also on production): Voxel lighting engine with a better tone map, HDR / unconstrained brightness implementation, and less light bleed.
  • Future: Shadow mapping engine that is meant to have much better shadows and lights and refreshing much faster. If you using Future is Bright, you should be using this.

If you using Future, you will need to set your graphics level to a higher number (5 maybe?). The intent for production will be to use Shadow-mapping for high graphic settings, and the new Voxel system for low end devices like low end PCs and mobile.


#9

Something I like to do is have the Brightness set to only .4 or .5 for light points that are emitting over a large surface or area. Smaller spots of light, or ‘detail light points’ as I call them, I usually will have at 1 or 2 brightness so it shines over the lesser main light points. It does take a lot of playing around but for starters I would keep the brightness level down in the .4-.6 range, and possibly adjust the colour of the light being emitted.


#10

I can confirm this, somewhat. I use 0.75 for one of my school-related projects.


#11

Well I keep my graphics on low in game now just to save some CPU and I assume that graphics set data goes into studio, could be the reason for the patches but still it is one big white patch that does not look to cool, like they need to spread it out slightly, so that it is not fully bright at 15 when the max brightness is 40.


#12

Hey melm, how do you get those excellent shadow effects? and those beautiful reflections on the ground?. Afaik whatever light source i use, none of them produce the same effect?


#13

How do i get those very sharp shadows instead of puffy ones like these?
Desktop_190209_1537


#14

You need to download Future is Bright v16 in order to use the more defined shadows. You can download it here. Be sure to change Lighting.Technology to Future.


#15

Will those changes reflect ingame or…?

Desktop_190209_1917


#16

By in-game, I’m assuming you mean the client.

No. For now, Future is Bright is reserved for the custom build of Studio only (except for Voxel mode, which is available in the client right now and normal Studio). The new lighting technology should ship this year, so just wait patiently.

Also nice build :+1:

edit: Just a reminder, only PointLights will cast shadows in v16. SpotLights and SurfaceLights do not cast shadows.


#17

Excellent news!
I cant wait for FiB to drop this year!


#18

I feel I should say this: it’s not a bug.

The reason why it looks this way is because of the new tonemapper that gives off more contrast. In Legacy, the lack of contrast hid the voxels, but now with the tonemapper in Voxel the contrast makes it more “patchy.” You should probably just turn down the brightness of the light and you’ll be fine.