Using % in Headers?

Hey everyone.

I’m trying to make a Roblox - Twitter Module but Twitter Tokens have % in them, when I send a request with the token in the header, I get this error:

I’ve tried removing the %'s and adding \'s before them (\%) but neither of these worked.

I have also tried UrlEncoding it and JsonEncoding it but these did not work either.

Are there any work arounds to this?

1 Like

Hello, there is a post that is identical to this. Please search the devforum for similar topics to the one you plan to create before making it.

The error was never solved. [char]

There is probably not a way to avoid this, even encoding it as \x25 doesn’t work. You will need to find a way to send the request without the % in the header or use a proxy server to send the request.

1 Like

Does anyone have a resolution to this yet?

Have you ever found a solution or a way around this yet?

Unfortunately no.

If you need to use % or any restricted symbols you’ll need to make a proxy that can put that stuff in headers for you.

Dang, I figured that would be the case. Thanks for the response though!

1 Like