Values claims ti be changing but isnt detected by other scripts or explorer

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    Im trying ti change a value, quite simple
  2. What is the issue? Include screenshots / videos if possible!
    When i change the value, it changes in the printing of the value, but in explorer and in other script it doesnt change
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I have tried printing it in other scripts but it doesnt seem to work
    After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

For a anyone asking, Yes its a server script

local DEF = Buffs.DEF.Value
    print(DEF)  -- prints 100 aka normal values
    -- Defense UP  20%
    DEF = DEF + (DEF / 100 * 20) 
    print(DEF)  -- prints 120, but isnr 120 in explorer or anywhere else i print it 

Please do not ask people to write entire scripts or design entire systems for you. If you can’t answer the three questions above, you should probably pick a different category.

This happens because you’re retrieving and storing the numerical value of the property. To avoid this, set your DEF variable to Buffs.DEF, and on the other lines, reference DEF.Value.