Various Unions, FileMeshes, and Animations not loading for my computer's specific Client


#1

Been having this issue for the past 5 days. A large random variety of Unions, Meshes, and Animations I’ve had, some from years ago and others 2 weeks ago, are failing to load their appearance on my computer, in Studio and in game. For other users and when I use a different computer, however, everything loads in just fine. I’ve tried copying them over to other places, and they still don’t load. It appears all the collisions still work fine on the unions though.

The invisible model above was made up of unions that were about 8 months old, untouched. The suit torsos were made about a month ago, and for whatever reason 2 of them fail to load. It’s odd to me that the Unions that didn’t load were also all in a specific model. Trying to un-separate the unions makes them disappear.

I’ve tried completely uninstalling ROBLOX (Going to Programs > Uninstall > Roblox Studio) and reinstalling, but the issue is still persistent. Also tried deleting local files, and it is still happening.


Broken Assets: Failed to resolve Texture Format (shown with 2 computers)
Various Assets not working - pt. 2
#2

Hi @JustAnAverageTree

Thanks for bringing this issue to our attention. Can you provide us with a repro file along with the direct link to these assets. Having this information will help us identify and reproduce the issue from our end. Feel free to privately message me the information if needed.


#3

Also system specs would be nice.


#4

Thanks for the quick response. I have attached as many invisible assets as I’ve noticed (including the ring file mesh, which has failed to load also) as an .rbxmx, and here’s a link to them as a model. Not sure if it’s worth mentioning, but the broken unions on the model’s thumbnail load fine for me, but when I put the model into a place on my client / computer they still remain broken. I’ve also provided an image of my system specs.

Broken Assets.rbxmx (1.2 MB)
I can’t say I know what a repro file is unfortunately, but I could provide one with more information on what it is.

I’d also like to inform you that the temple model I’ve also provided (seen as invisible in the original post’s picture) for whatever reason, from yesterday to today, is loading it’s appearance fine on my computer now. It seems none of the other broken unions have loaded miraculously for me like this, but for whatever reason this one has. I can also un-union all the now loaded unions in this model fine, while before they would disappear.

And lastly, I was experimenting with the unions and found that, when I tried to separate an invisible broken one, the first time I did it i got this error in the output:

SolidModelContentProvider failed to process https://assetgame.roblox.com/asset/?id=216429239 because Unrecognized format

Hoping this helps. Again, thanks for the quick response. Hope you can fix it!


#5

I’m not sure if this is related, but I’m having a noticeable amount of my game players experience rendering issues as well. They have some Mesh’s & CSG’s physics render on their client but not the actual model. So they can run up to the model, see the shadows and collide with it, but they won’t actually ever see it.

Here’s a side by side image of what my client see’s, vs what I had a player experience. Also I think it’s worth noting that it’s the same mesh’s that all the players experiencing the bug have the rendering issues with, not different ones.


#6

This happened to me about a year ago in team create


#7

When did this start? Which platform do the users report this from? Do their client logs (in dev console) have errors indicating that this asset didn’t load?

Also please add a link to the place so that we can see if we can reproduce this.


#8

About a month ago for some, and others just recently are starting to experience the same on and off. All the affected users are experiencing the bug on computer. Dev console shows no asset errors, but here’s the logs from him anyway.


Here’s the game place, but it’s a Universe so the link will be a lobby.

Here’s the actual place from the universe if needed.


#9

So because this bug is still effecting me, I am going to show exactly what the bug is as clear as possible. I am using a Decal that was not made by me, as the glitch doesn’t seem to occur based off whether I published the asset or not.

First, I have Computer A, which is the computer I have been having this issue with for about a month now.

As you can see, the decal has failed to load. In the output, the error “Failed to resolve texture format” is there with the decals corresponding ID.

Now, here’s Computer B. This is in the exact same place but just on a different computer, and is logged in with the same roblox account. They are also both on the same Wi-Fi connection.


As you can see, the decal has loaded absolutely fine without any errors in the output. I have also tried this on 3 other computers with completely different specs, and it all works.

Although I am showing a decal, Computer A is also failing to load various Unions, Sounds, Decals, and Meshes. On Computer A, I have tried completely deleting the ROBLOX folder in Local, uninstalling the roblox application, and reinstalling it to see if that would solve the issue. It did not. If there is a more “advanced” way of uninstalling Roblox where I should try uninstalling certain folders that I don’t know about, then I would try that.

The only connection between all these assets not loading is that all that assets that fail to load were in this place. I have not had any assets fail to load that were not in this place. If you would like edit permissions for it or a file copy of the place itself, DM me.

If you need any more information, ask me for it. I hope this issue can be resolved soon, it has completely impaired my ability to develop.

Also if you need it, here are Computer A’s specs.


#10

Due to this bug being a repeat of one that has been occurring for me in the recent past, I will provide the link to that post here and will be referencing it throughout this one, as pretty much all of this is a repeat of that post.

Since my last post, the shown broken assets after a Studio update appeared to load fine, and all the assets in my game appeared to be visible. Since yesterday, however, it seems my Client has now decided it won’t load specifically my game’s spaceship assets. All the assets were part of a single place, and it appears all the assets in that place are unable to load on my Client. I’ve tried seeing if these assets would load for me in another place and they have not, but sure enough, they load fine on everyone else’s computer.

Here’s a screenshot of the studio place itself. Shown is the Unions & Mesh parts that have failed to load, along with all output errors the place got.

I’ve also attached the place in this thread.

This issue is extremely frustrating and has severely halted my schedule for getting work done. If you need any more information then please inform me, I would be more than happy to provide it if it means this bug can be fixed as soon as possible.Building Place.rbxl (2.3 MB)


#11

Are you able to download the assets directly? Just click https://assetgame.roblox.com/asset/?id=170534758, save the file locally as a.png, and try to view it. If not, open the file with e.g. Notepad and see if it looks like a webpage.


#12

I was able to open the asset and it looked like this. I believe this is one of the images used on one of the models.


#13

By the way, what do you have selected for Graphics Mode in Rendering options? It looks almost like you’ve got D3D9 selected. That should be set to Automatic for most users.


#14

I believe I have everything set to Automatic. Here are the settings displayed for me

.


#19

This problem still persists…