Viewmodel Animating (Please help)

I want to animate a viewmodel but the animations will not show up. There are no errors. I have tried deleting the humanoid / using an AnimationController instead and switching the parent of my motor6d’s

local player = game.Players.LocalPlayer
local char = script.Parent
local cam = workspace.Camera
local run = game:GetService("RunService")
local gun = game.ReplicatedStorage.Viewmodel:Clone()

	gun:SetPrimaryPartCFrame(cam.CFrame *,0,0.5))

gun.Parent = workspace

local LoadedAnimation = gun.anim:LoadAnimation(gun.idle)


print ("Loaded")


1 Like

You can’t play ANY animation, unless you have a Humanoid present in your model, AND there must be a rig that the Roblox Animation software can verify.

Use an AnimationController to play your animations. Insert the AnimationController in the viewmodel.

Thats one of the solutions i tried. Did you read the post?

1 Like

Have you heard of AnimationControllers? And yes ive rigged the viewmodel

if you can send us a video. It’ll be great! Since there’s a lot of reason why the animation wont show up

Try adding a wait() first. That a most common problem that people experience

1 Like
local AC ="AnimationController")
AC.Parent = nil --change to instance ac should be parented to

Sorry if my audio sounds a bit deep fried; I havent set up my recording software.

I forgot to mention “anim” in the viewmodel is actually an AnimationController