Viewmodel parts invisible without humanoid

I’ve got a viewmodel that I store in the camera, and for some reason the gun parts aren’t visible unless there’s a humanoid in the viewmodel. I don’t want to use a humanoid since I’ve noticed steep FPS drops when humanoids are used, so I use animation controller instead. There is no reason that the gun parts should be invisible, since the transparency and localtransparencymodifier are both set to 0 and the viewmodel itself isn’t even part of the character. Here’s a video of the issue

also, the problem isn’t the same for the melee and grenade slots, but the render settings on their meshes are the same as on the primary and secondary.

i just noticed that it actually doesn’t happen with all models, looks like about half of them are invisible and the rest aren’t

this complicates things because i have no clue what the difference is

okay so nobody decided to take up this topic, that happens sometimes but in case anyone needs this in the future, the problem was with the levelofdetail property of the models. for some reason on some of them, they don’t render when it’s set to automatic and i simply had to switch it to streamingmesh, and vice versa. just play around with that property I’m sure it will eventually work but I have no clue as to what actually causes the problem, I still believe it’s a glitch and that is the only solution for now.

1 Like